Download

A question about auto exposure inside forest.

I followed the tutorial over at: http://docs.unrealengine.com/latest/INT/Engine/OpenWorldTools/ProceduralFoliage/QuickStart/6/index.html where we was creating something that looks like the picture below.

This is what I have so far and I been trying to adjust the AUTO EXPOSURE with no luck.

As you can see the shadows are super dark while the horizon is super bright.

How could I make it so the forest isn’t so dark but still show nice shadows while when I’m looking out of the forest I don’t get blinded?

I am kind of looking for something like this in DayZ, tho they don’t have shadows turned on in this screenshot, I would still like it to have decent shadows if the player wishes to use them.

looking at the screenshot, your bloom looks too overpowered and your skylight is to soft. try reduce bloom a tad and up your skylight intensity a bit too. try to find a balance before messing around with auto exposure if you want to disable auto brightness set min and max to the same value. try it out, take a screenshot and let us have a look:)

Another quick question while I am doing what you said. Should I have a post process volume and a lightmass importance volume in my level? Some levels I see a post process volume just sitting there as a tiny box and other levels I see the post process volume being stretched to cover the whole landscape. Always confuses me on which to do.

light mass importance volume is only needed if you use static lighting, going by your dynamic sky, you use a movable light, so you never need to build lighting or use Light mass volumes.
for PP (post process) you can have many different ones in a level, if you want a global one as well you just need to mark the box called unbound and it will cover the whole level regardless of its size

I have the worst luck when trying to fix stuff, trying to load my foliage for my foliage volume and it’s stuck on loading at 75% for like 20 min now. most likely gonna have to watch that tutorial and build it again.

Aight here is what I got now

Bloom: 0.1 on my Post Process Volume
Skylight Intensity: 3.0
Auto Exposure: 0.5 min 0.5 max

My Blueprint window.png

Maybe it’s because I have a lot more trees in my scene than the screenshot they posted and all the trees and drowning out the light.

the mid tones are looking a lot better now :slight_smile: put a cube map on your skylight and it will tone down the blueish glow from the skylight, right now its just looking at your sky and going, wow that’s blue:) using a cube map will give it something more natural to look at
here is a screenshot of my skylight settings for reference

Aren’t those auto exposure values really odd? I remember the default values are in the 0.8 - 0.98 range or so?

setting them to the same value [any number] just turns the effect off

that water looks really good, make it yourself? or grab it from somewhere?

i tried 1.0 and it was really dark still in the forest, 0.5 was the best

Here is what I came up with this morning. Not exactly as nice looking as yours, but its looking better

looking great :smiley:
the water i use is a mix up of 3 or 4 tuts i have seen around, it has a few kinks, once i have worked them out i will make a tut and post it

Appreciate it, got a quick question about landscape size and also culling I can’t seem to fix anywhere.

My grass and trees cull at a pretty short distance and no matter what I set the culling to on them it doesn’t change on my level. In an open world game how far is to far or to short on culling? Don’t want a player to look like 3 feet and the grass be gone. Looking more of an effect like how DayZ set their game up.

Also while we are talking about DayZ, how big is the default landscape in the Editor? it defaults to 100x100 when I create a new landscape, so is that 1km x 1km? As DayZ Chernarus map is 225 sq km, I’m wanting to set my map about the same size as that to work with.

As you can see in my landscape this is the default 100x100 landscape, mmy trees and grass are culled pretty hard.

Also, that’s still way too bright, looking like some old school Windows 95 graphics. And I got the bloom down to 0.1

depending on how you placed your foliage, cull distance can be in a few places. i keep min at 0 and max at what ever looks good for the level.
if you simply used the foliage tool and painted them it should be under the setting for that instance:

if you used a grass type like this open that up and you should find the cull here:

UE4.11.1_Error.JPG

if you used a Foliage type like this for procedural spawning its located here:

the landscape size all depends on the overall resolution 1 pixel = 1 UU = 1 meter

so if you create a landscape and press fill world you end up with 8161x8161 or 8 sq kilometers. to get anything larger its recommended using tiled landscapes like this

as for your brightness, im not to sure how your sky blueprint works, i was going to by the ultra dynamic sky but opted to make my own, my point is though you can try setting the sun directional light intensity lower, however your sky BP may change it when you play so watch out for that.

ixicalibur I really appreciate your responses and the time you took to help. I did use the procedural foliage volume to spawn in my trees, I was following that Open World Tools demo, and I painted on the grass with the landscape material I just added the grass mesh to my grass layer and set my brush to like 65k and painted.

I set the culling on my trees to min 0 and max 300k and this is what I get I also set my grass to 0 and 300k max and nothing changes.

Also if you don’t mind, you said it depends on the overall resolution, what if I change the X & Y scale values to like 100k x 100k instead of changing the actual resolution? Just gonna lag really bad? Does that not make my landscape bigger??

ok so i did a bit of testing, i have the same results as you, it seemed hard capped @ around 60000.
it turns out that the foliage systems use screen percentage to cull objects that are so small you couldn’t see a few of them anyway. obviously for grass that’s not great unless your texture blends perfectly with it.
the fix is a console command to lower the threshold:
foliage.MinimumScreenSize 1
that would cull anything under 1% of your screen size, the lower you go the more you will see smaller objects.
if that works read my other post here to see how to add it to your ini files so it will auto run
with ini console commands you need to put at = at the end of the command and then your value:
foliage.MinimumScreenSize 1 would become foliage.MinimumScreenSize=1

The foliage.MinimumScreenSize 1 set the culling to where nothing showed. Grass and trees didn’t show. I had to use 0.000001 and that still sets it at the same distance as I had before

I went into my grass texture and under Adjustments I changed the Max Alpha from 1 to 2 and it gives me the effect you see below. Gonna try to change the max culling on my actual grass now and see what happens.

So I went into my Landscape Grass Type and changed max culling to 300,000 and it filled my entire landscape up with grass.

That brings the next question, as far as I can tell games like Fallout 4 has no grass culling and I run it just fine on my comp. How can I ensure that if I turn grass culling off inside of UE that it will run fine on a finished product?

glad you got it working :smiley: most games cull pretty hard even fallout 4 check this out to see it.
its not really feasible to have a large amount of grass all over the map without any culling. our job as developers is to trick the player into thinking it is, only showing what they need to see to believe it. its the same with rain effects, you dont put rain all over the map, that would kill performance, you attach a small amount to the player and have it follow him around.

Ah, so the grass does cull in fallout pretty bad, they just mask it out really well. So that means I need to create a better looking base material that looks a lot like my grass to trick the players then. As you can see in my screenshots, it’s pretty noticeable.

Appreciate all your help ixicalibur, learned a lot so far from you.