Download

A bit of a problem with LUT files

I am experiencing a bit of a problem with using color lookup tables.

It seems that my lookup tables in particular cause my scene to be way too dark in Unreal, when the same lookup tables have no problem being shown correctly in Photoshop. Even the lookup table that is supposedly neutral gives me colors that are way too dark. As can be seen in the picture that I uploaded; in the first picture I have the original scene without any color corrections. The second screen has the neutral lut applied. The second row shows a scene where I applied a lut file I made with Davinci Resolve. The second blue one has this lut file applied to the neutral lut. As you can see, in both instances the neutral lut colors don’t match the ones I am supposed to be getting.

Does anyone know how to solve this? I have tried a variety of neutral lut files, but they all seem to give the exact same color problems (all the exact same shade of way too dark).

Does your laptop’s GPU support DX11?

Yeah, it does. It’s a fairly strong computer, bought only recently.

Anyway, no, I found the problem. Turns out it was the compression settings. When I was importing the lut files, I hadn’t set them to HDR compression, causing the darkness in the pictures. When I set the neutral color lut to HDR, the problem was immediately solved.

Actually you should put the Texture Group on ColorLookupTable and leave the compression on TC Default.

Read this for more info. :slight_smile:

Maximum-Dev is correct. It should work just fine with group set to ColorLookupTable and compression at TC_Default.

Thanks! I wonder how I ever missed that part, considering it is right there and not all that hard to find. Yeah, I will do the proper way and do it as you guys described. Works like a charm!