Download

8k Textures... Can't for the life of me figure out how to enable them

Been poking around the internet for over a week trying everything to enable 8k textures, but everything I’ve tried fails to get these higher resolution images through.

8c916ead0b9325c4efd9fb84a6b2b0366d797468.jpeg

Here’s where it’s at right now, it’s displaying at 8k in the previewer, but in engine still stuck at 4k.

Any help is appreciated!

IIRC, Kite Demo has 8K textures. Not sure if any are displayed in-game at that resolution though.

The question I would ask is, if this is for a regular usage, do you really need 8K? They are seriously inefficient, even when compared to using multiple textures of smaller size. Shifting huge blocks of texture memory around so often will quickly use up your pool.

This doc should help you get it working. You’ll have to edit an .ini file to get anything larger than 4096 in-game.

@Jamsh: Not worried about effeciency, I’m trying to get as large of sprite sheets as I can for a non run time cinematic and particle effects.
@Tim: Thanks for the link, that’s exactly the document I was following! You’ll notice in the attached image I had modified the defaultengine.ini file… but thus far no luck.

Thanks for chiming in guys.

Is there a way to have hdr images (for skybox) rendered in-game in higher than 512x512 without having to mess with the source files and recompile?

It’s been a while since I’ve set it up but I’ll give this a try next week and offer some feedback if its different than the doc or something seems unclear. Feel free to reply and tag me if you dont hear back at some point next week.

Thanks so much Tim, I’ll poke at this a little bit more and have some of the team try their hand as well. Maybe its a hardware issue but we will certainly contact you in the coming days if we’re still stuck on this.

@crazyfingers619

It looks like there was a change in where this information get set and stored now. The doc hasn’t been updated to reflect this information, though.

The settings now get stored and set a little differently than what that documentation shows. You can set it a couple of different ways nows.

For Specific Project:

In the [YourProject]/Config/DeviceProfiles.ini You can set to easily generate a DefaultDeviceProfiles.ini by doing the following:

  • Go to Window > Developer Tools > Device Profiles.
  • Then in this window, click the “Save as Default” at the top.
  • Now open the your project > config and open the DefaultDeviceProfiles.ini file.
  • Edit any of the LODGroups value for MaxLODSize to be 8192 instead of the max of 4096.
  • Save this and then reopen your project. You should be able to open the texture now and see the correct in-game resolution. If not, make sure that the “Mip Gen Settings” is set to “From Texture Group.”

All Projects:

Alternatively, if you want this to be true for any project and not project specific you can do the following:

  • Open your Engine Installation location then go to Engine/Config and open BaseDeviceProfiles.ini.
  • All profiles will be listed here. Scroll down to the section labled:

[/Script/Engine.TextureLODSettings] @TextureLODGroups=Group

  • Under here you will find all the TextureLODGroups. Change the MaxLODSize values you need here. The default values are set to 4096.
  • Save and close this file.
  • Restart the project or launch any project.

You should now see 8192 for texture size. If not, make sure the Mip Gen Settings drop-down is set to “From Texture Group”.

That should hopefully get you squared away. Let me know if you run into any issues or have any questions for getting this working.

Totally did the trick! Thanks for the prudent reply Tim, feels good to have higher quality/ longer running sprite sheets.

Thanks TIM! Took me awhile of searching to find this! Everything else landed me to the old methods of editing DefaultEngine.ini and BaseEngine.ini.

[USER=“4894”]Tim Hobson[/USER] I have tried the things you described (both the per-project one and the per-engine one), but the max size is still 4096.

Your post is from 2016, so I assume its outdated again? Could you describe a newer method of enabling 8K textures?

May I have question. It’s possible to define TextureLODGroups per configuration? Let’s say Android_Mid will have only 1k textures, Android_Low only 512 textures?

[USER=“4894”]Tim Hobson[/USER]

I tried to change the DefaultDeviceProfiles.ini for a specific project in 4.21 and now the editor doesn’t start. And not only the project I wanted to modify but the whole 4.21 won’t open at all.

Any particular reason you want to use 8k textures?? If you’re concerned about texture compression/artifacts you should consider just using 4k textures with “BC7 compression”. You can change from default texture compression to BC7 in the Texture Editor UI. BC7 has almost no visible compression artifacts compared to the default.

https://docs.unrealengine.com/en-us/…ties/Interface

Be sure to set the targeted RHI to DirectX 11 in the project settings, otherwise BC7 will just be uncompressed and will not work.

(DirectX 10 doesn’t support BC7 textures)