4K Fullscreen Output

I’m making a game for a client that’s going to play in 4K on a GTX 1070. Unfortunately when I packaged the game (development build) and run it fullscreen on a 4KTV it refuses to playback on any resolution other than 1080p. I tried r.setres 3840x2160, didn’t work. I searched the Answer Hub and found other users with the same issue, but nothing from Epic on how to fix it.

When will this engine support 4K playback? If it doesn’t, what should I do now? I already tested the resolution by running r.Screenpercentage 200 and it handles 60 FPS like a breeze, even in the most difficult segments. This is on a GTX 1070, a graphics card you can now find in a LAPTOP for ~$1,100. Next generation graphics cards scheduled to release later this year in the $200 price range will be capable of running modern 4k gaming at 60 FPS, with tessellation, DFAO, physically based + deferred lighting, temporal anti aliasing, etc. etc. at Epic/Very High scalability settings. The thought that this engine still constrains itself to 1080p is absolutely ludicrous. Even the UI is blurred because of this artificial limitation.

I made a promise to my client, and I intend to keep it. I need a 4K solution for my project right now. Does anyone have one?

EDIT: So, I needed a DefaultGameUserSettings.ini file in the config folder. Also, the project was previously running in 720p, not 1080p. 4K 60 FPS does not work on a 1070 with all the graphics I have, but the UI can output a nice and clean 4K with the game running at half that resolution. I wish there was an easier way for the game to support multiple resolutions via console commands or Blueprint nodes or device profiles. Console commands were enough to work in the past. It boggles me why those simple solutions don’t work now.

Try having a look at this documentation that went live recently: