Download

40000+ shader compiling and its add up on hitting save

soo…what is going on here?
I have a landscape with a resolution of 2017x2017 and to me not a super complicated material. 6 a 7 layers, some planar projections, triplanar projections…
the problem:
when I want to edit some material stuff, the shader needs to compile around 20000 shaders.
When I want to save the material while the shader is compiling it just adds up…I can get to 80000 shader compiling before I decide to stop Unreal.
The strange thing, when restarting unreal, it just want to compile arond 20000 shaders and not the 40k or 80k shaders just a few minutes ago…
so what it going on here?
Are there any workarounds? Is it a bug, slow hardware?? (iMac windows bootcamp 2015)
regards! T

one tip is don’t press compile and then save. Pressing save will already do a compile. If you press compile and then save you are telling it to compile twice. Annoying I know; its been reported. You should be able to just press save and it will save and only compile once.

You can usually lower the permutations by going into the usage flags of the material and unchecking the ones you don’t need, and making sure tessellation is off etc. Each new permutation can double the amount of shaders. I usually only see around 4000 shaders compile when I compile my landscape materials when I keep an eye on those things.

ie, if you don’t need static lighting, turn it off there. same for any other options expcet for landscape obviously.

Thnx! Excellent tip! I’ll make sure that I keep watching those as well!
regards! T