4.9.2 Instability

Hey all

Im experiencing a lot of instability since the last update. My editor crashes more then often, sometimes even without any error.
I’ve noticed that it usually happens when i try and move or delete some of the files or when i change variable type.

Is it just me? Maybe im pushing it too much, i got a lot of blueprints opened at the time.

Also i’ve noticed that deleting something doesn’t work when i use the keyboard, i have to right click and delete it from the drop down.

If i can provide any additional info and help, please let me know.

Thanks, Miki

Hi miki86,

Do these errors occur on a clean, blank project with no additional content or is it limited to one project? What steps can I take to reproduce this on my end? Can you post your crash callstack, logs (\Unreal Projects\PROJECTNAME\saved\logs), and dxdiag so I can take a look and see what may be going on?


No, it’s not a clean project.

I ran a test on my blueprints through session frontend and apparently changing stuff in my parent class caused all of it’s children to break. So i tried fixing the child classes and it first it wouldn’t let me, crashed as soon as i tried to open or delete them.
After couple of times it finally let me fix them. Since then i haven’t had any crashes, i still have a couple of errors popping out in session frontend though.

I’ve noticed that it stutters for a second or two when i update the parent class. I have up to 8 child classes if that matters.

These minidumps are all from yesterday

Thank you.

What specific changes did you make to the parent class? Have you tried compiling the parent class or the children after compiling the parent?

I tried adding new variables and components, if i remember correctly it crashed soon as i compiled, maybe even on pressing the new var button.

I couldn’t get children classes to open after that, had to restart couple of times. Children already had some components on them, and stuff in the event graph, that’s probably the cause of it, because soon it let me to open them i’ve noticed that the existing components changed their name to collider_0…and so on

I attempted to reproduce this on my end but thus far have been unable to do so. These are the steps I took below, please let me know if there is something I have missed or that needs to be added to reproduce this on my end:

  1. Open Editor (any project)
  2. Select any blueprint or create a new blueprint actor
  3. Create child based on actor (RMB in content browser>Create child based on this)
  4. Create 2 additional children based on the child actor following step 2.
  5. In original parent, add several static mesh components, compile (no crash, no error appears)
  6. Make adjustments to static mesh component (change scale, change static mesh actor, etc.
  7. Compile

At this point, I have seen no crashes or warnings that could be attributed to altering the parent blueprint. Do you have any other steps I can take that may be able to reproduce this on my end?

Ok, this is my scenario, i had about 8 actor blueprints, all of them had different stuff in graph editor and probably couple of different components.

Then i decided to reparent them to a new custom blueprint. I haven’t made any changes to them since i add the parent blueprint class.
Then i started working on the parent class, adding components and variables is what caused it to crash.

I really don’t know why, like somehow they got damaged because as i mentioned i couldn’t even delete the children blueprints after the crash, let alone open them. And i think that trying to delete them, just closed the editor without giving any errors.

Hi miki86,

I attempted this with the updated steps and still could not reproduce the error on my end.

  • Were these 8 actors originally parented to a different blueprint or were they all based directly off of a single blueprint type, such as “actor”?
  • Did they have any blueprint script that were referencing values from a previous parent that was still being referenced?
  • Could you send me a copy of the assets in question so I can try to reproduce this with the specific assets that are crashing?

All of them were based of actor class, so i had no other parent class before.

I managed to get 4 of them from a backup before i attempted to change the parent class. Attached bellow.
I’ll try doing the same and see what comes out.

Hi miki86,

Unfortunately, even with these assets I have not been able to reproduce this error on my end. Are there any other steps I can take that may cause this to occur?

I figured, it worked for me as well.

I think i have to do a clean up and delete unnecessary files and fix those warning that came out. I did had another crash today though, different blueprint, first compile gave error, second crashed the editor.

On a side note, there is something else i’ve noticed.

Here is the recording:

Some of my components strangely keep rotating by 45 degrees when i compile, all of them except the mesh. Not only in the viewport but also in my game level.
I must be the only one having these strange glitches.

Hi miki86,

Can you send me a copy of your project along with detailed steps to reproduce each error you have listed here? I will do what I can to reproduce them on my end.

I’m running into the same issues - but it has to do with scaling a Speedtree object… crashes every time with 4.9.2. Even with a blank project.

I’m using a one year old Mac Pro… 4.8.3 had no such issues and still doesn’t.

Every time.

Thanks -

I can’t send you the whole project, its over 2.5gb and the project is nearly done. Plus im not getting same errors again, it appears to be fixed. I went through the logs and checked any blueprint that was giving warnings.

I can send you the asset that i used in the video, because that problem is still occurring. It all started happening after 4.9.2 update. I mean i had a few crashes here and there but mostly because it was my fault.

I packed the parent class too.

Update on the video above, i opened the blueprint and now my mesh was rotated by 90 degrees, i know i didn’t left it like that.

This is amazing, i wanted to show you how the objects keep jumping when i try to rotate them but on the video it looks ok, my recording software didn’t caught that. Like its trying to keep the object 90 degrees each frame from where im actually rotating but soon as i let go it goes back to normal.

By the way i haven’t mentioned that this problem doesn’t happen on all of my blueprints.

Hi miki86,

Unfortunately I cannot open the proximity mine asset as it is currently parented to “none”, if you could, try migrating the trouble assets to a clean, blank project and upload that project here, I’ll be happy to take a look.

I can’t upload it here its 5mb file size limit, but here is a link for dropbox.
Try opening the child blueprint and rotate the mesh or anything else, i have the same issue in the new project as well.

I solved the rotating issue by copying the same blueprint, the original is bugging and the copy works fine.

I had another crash today while trying to compile parent blueprint, no minidumps or error report it just froze, but this is the log file:

link text

I got a bunch of errors on compile, tried compiling again and it crashed. I opened the project again, same blueprint, no errors, everything is working fine.

Unfortunately, even trying this project and rotating/compiling the blueprint in the project I have been unable to reproduce this error on my end or any crashes. Try running a verify on your engine build by going to the launcher>library and press the dropdown>verify option on your 4.9 build.

I did a fresh install yesterday, that didn’t helped much. I’m still getting crashes and even things that worked now don’t, like multiplayer testing. I had no problem with that before, now im getting a black screen on my client soon as i start hosting. None of the fixes help.

I haven’t changed any of my components or drivers, the only thing that could have changed is that maybe the windows 10 got updated.

Also running the automation test on my blueprints gives me couple of strange errors, like missing mesh ([compiler Teleport_190] Error The property associated with Teleport Mesh could not be found) and soon as i open the blueprint in question, editor crashes:

[2015.10.12-18.16.47:813][567]LogWindows: === Critical error: ===
Fatal error!
[2015.10.12-18.16.48:006][567]LogExit: Executing StaticShutdownAfterError
[2015.10.12-18.16.48:044][567]LogPhysics:Warning: PHYSX: ..\..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.
[2015.10.12-18.16.48:050][567]LogWindows: FPlatformMisc::RequestExit(1)

Mesh is there and i can compile that blueprint with no problems soon as i restart the editor.
I tried verifying the new installed copy as you suggested and it made backup of couple of files, does that mean that those files were broken?

I even tried migrating all my files to a new project.
Im about to try new beta driver for my gpu, because i honestly don’t know what else could be causing problems.

This is the automation report, only errors and warnings:
link text

Do any of your assets have circular references in them? There is a known issue with circular references, I’d like to know if this is where your error is occurring. If not, what was added to your blueprints just before these crashes started to occur?