[4.9.2] Can't generate VS project files for any C++ project

Hello guys, I’m surprisingly faced with an issue with project files generating. I can’t understand why it appears because it was working fine before on 4.9.2. I use binary version of engine from launcher and tried to reinstall it, but nothing changed. I’m also tried to reinstall Visual Studio 2013, but this error appears even if VS uninstalled.

Running C:/Program Files/Epic
-projectfiles -project=“D:/Projects/Test/TestProject.uproject”
-game -rocket -progress Discovering modules, targets and source code for
game… Errors detected while
c:\Program Files\Epic
: error CS0115:
no suitable method found to override
UnrealBuildTool Exception: ERROR:
UnrealBuildTool encountered an error
while compiling source files

Please help me to find workaround. Thanks.

Hey -

Is this unique to a single project not being able to compile or is this all projects? Are you trying to compile through VS or are you right clicking on the .uproject file and selecting “Generate Visual Studio project files”? Are you able to create new code projects? Does the same thing happen for other versions of the engine (4.8)?


Hey ,

it’s actual for all c++ projects. I’m tried by clicking on the .uproject file and selecting “Generate Visual Studio project files” option. I’m not able to create new code projects - still got this error.

Does the same thing happen for other
versions of the engine (4.8)?
No, I just installed 4.10 preview now and “Generate Visual Studio project files” working fine with this version.


I’m already tried to verify engine in Launcher before I posted this question. It doesn’t help.

It appears that the compiler is trying to write an override function for ForceNameAsForDevelopment() but can’t find the function it’s trying to override. If you are using a using a binary version of the editor then I would suggest trying to Verify the engine version using the drop down arrow for that particular version in the Library tab of the launcher.


Here is another post with the same issue you’re describing. Can you try the solutions posted by Valkorian and JamieT187 to see if either helps in your case?

I think it’s not the same issue. Logs are different. Also I’m work on Windows 10 and I’m pretty sure that this issue is not related to Windows 8.1 SDK, because UE 4.10 preview works good. But I’m still need 4.9.2.

Just in case I tried solutions from Valkorian and JamieT187 – still doesn’t work…

Ok, I finally found a solution. I uninstalled 4.9.2 and found folder “C:\Program Files\Epic Games\4.9”. I removed it and installed engine again – now generating of VS files works good.

Before removing I made a copy of this folder with wrong config files. If I merge this wrong folder with new engine folder – this issue appears again. You can check it to find cause of failure.

Archived folder (8 mb): MEGA