[4.9.1] Reflections view issues

Hello everyone.

I just noticed a small but annoying bug when I turn on the Reflections view. It worked ok in 4.8. I haven’t tried in 4.9, but in 4.9.1 there are some problems. It shows black areas or even the full screen black in certain conditions:

In other views, like Lit and Detail Lighting, antialiasing does not have effect on the issue, only in Reflections view. But selecting the object still shows darker reflections in those views.

Greetings!

Hello PacoChan,

I just ran a simple test to verify what you are reporting, but was unable to reproduce the issue on my end. I have a few questions that you can answer in order to help determine the cause of the issue.

  • Can you reproduce this in a new blank project in the version you are reporting?
  • Would you mind providing me with your ‘DxDiag’ so I can take a look at your system’s specifications?
  • If you are able to reproduce this issue a new blank project, can you provide me with some simple steps to follow in order to get the issue to appear on my end as well?

If you have any other comments or questions please let me know.

Thank you,

Andrew Hurley

Hi. I created a new blank project and created some walls by duplicating the default floor. And at first I didn’t have the issue. However, what triggered it was to enable Force no precomputed lighting and building the level.

In the reflections view, almost everything turned black, or there was something not black in the corners and by moving the camera, they turned permanently black. But in Lit view it was better.

In my original project I also had Force no precomputed lighting on, so it seems to be related with that. In 4.8 there was no problem with this.

link text

Hello PachoChan,

Looking over your description and your screenshots I was able to create a test using your exact steps.

I created a new blank project and duplicated the default floor. I also deleted the fog and added a point light just to add some more light without too much complexity.

I was able to reproduce what you see.

As you can see some areas are rather dark, but at certain angles you can still see some reflection returned. However, right now you have no information that is being returned to your cubemap. Essentially what is happening is that you are forcing the scene to return a reflection value when there is none being calculated. The engine does the best it can within that mode to show you where the reflections would take place.

This is the result after adding a sphere reflection capture.

This is a screenshot from our documentation on sphere and cube reflection captures.

What you are seeing within your project is intended behavior and the above is the step to return accurate reflection values within reflections view mode.

Thank you for reporting this.

Logan

Hi, thanks for your answer. But I forgot to mention that I actually added the Reflection capture sphere. And no, I don’t think this is an intended behavior. Let me show you two more screenshots.

The top one has the object unselected. The bottom one has the object selected. Just by selecting the object, the reflections break. And by unselecting it, they return to normal. This never happened with previous versions of the engine. And this happens apparently just by enabling Force no precomputed lighting and building the level. And as I said, sometimes, by disabling antialiasing in a post-process volume affects too.

Greetings!

Hello Paco,

I am sorry, I didn’t realize that you already had a reflections capture inside of your scene. I have tried on multiple projects to reproduce what you are experiencing by selecting another object while in reflection view mode.

I will continue to investigate this further.

Logan

Hello Paco,

I was unable to reproduce the complete black objects that you see. However I tested this in 4.8.3 and 4.9 as well as another version of the engine.

I definitely see some discrepancies between the versions. I saw a horizon that returned completely black when it should have been a softer blue.

I have entered a bug for this and attached this thread to it.

The ticket number is UE-21251.

I will keep you up to date with the progress of this issue. I do know that reflection view mode is something that has caused many issues and is currently being investigated.

Thank you for reporting this.

Logan