[4.8] VR isn't working anymore on Oculus DK2

Hi everyone!

I’ve just updated my UE4 to 4.8 version and my vr project isn’t working anymore :frowning:

The VR preview is always disabled and when I tried to run the console command: “stereo on” in standalone game, it doesn’t work. It worked on UE4 4.7.6 .

Can anyone help me please?
Thank you very much!

Hi there,

Epic confirmed a bug regarding this today: [4.8] VR preview sometimes doesn't work, bad GPU-utilisation - XR Development - Epic Developer Community Forums

Hmm, but in your case it seems like it’s not just not working but the button is disabled alltogether?

Hi ! Thank you for answering me!

Yeah, the VR preview button is always disabled for me, I’ve already closed and reopened the project and nothing :frowning: . It works on ue4 4.7.6

I’m using oculus sdk, and ue4 4.8. I tested with direct and extended mode.

Thank you very much!

Hello ,

If you update to the latest runtime does this allow you to click the VR preview?

Hi Rudy! Thank you for answering me!

I’ve just updated the oculus runtime to 0.6. The button “VR Preview” now is enabled, but it doesn’t work, it just shows a black screen on direct or extended mode.
The audio works fine, but no image is showing in my Oculus Rift, as you see in the pictures below:

And after click “VR Preview button”:

I can’t even set “stereo on” by blueprint in standalone game. I run as Standalone game, and when I ran the console command “stereo on”, it turned black, but the audio works…

After enter the “stereo on” command:

Thank you very much!

Wow… in fact it is unstable. I’ve just restart my computer and worked once, but the second time it just returned a white screen, and the third time a black screen. All of them the audio worked… Oo"

Welcome to the funny world of VR development in 2015 :wink:

I can report similar black screen for standalone with example project…

With a test project (third person example) with 4.8 and Oculus 0.6.0, I am able to repeatedly boot VR Preview seemingly fine, but I am unable to run stand alone without the black screen result when switching to VR with console ‘stereo on’, keyboard alt-enter, or blueprint EnableHMD where I see what looks like a single frame of the example which returns to a black screen as shown by above.

I have another issue with Oculus: I’ve got a scene where my player starts turned 180° (looking backwards) on Z-axes so, when I start the preview the look is ok (when the Oculus visualization starts…most of the time not), but when I started again it’s start turned 180° (looking forward) and alternating so every time that I restart the game.
If I play in standard mode (no VR preview) every time the scene starts perfectly

Hello ,

I was able to reproduce this issue on our end. I have written up a report ( UE-17125) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

Hi, sounds like bug UE-11247, reported Mar 21 '15: VR: Player start viewing direction is 90° off - XR Development - Epic Developer Community Forums (I posted a workaround there)

Thanks Rudy! :slight_smile:

I can report the same black screen in standalone stereo under 4.8.1, can you confirm that UE-17125 covers this issue, and if possible can you give an eta on this being addressed please? Many thanks

Hi there,

Epic didn’t fix this yet. The only known workaround is to close all other windows and tabs before starting a VR preview (or standalone process).

See [4.8] VR preview sometimes doesn't work, bad GPU-utilisation - XR Development - Epic Developer Community Forums for details.

Same issue for me in 4.8.1…sticking with 4.7 for VR for now.

Hello ,

As posted above please note that you can run the VR preview in 4.8 if all windows are closed (excluding the main editor window). I hope that this information helps.

Make it a great day

Hey Rudy, what is the state of this issue (UE-17125) ?

yes I’d also like to know the state of the issue please Rudy. Seems like a high priority thing. I updated to 4.8 to take use of some updated c++ functions but can’t test VR anymore.

Hello HuntaKiller,

I went ahead and double checked on this issue for you and it appears that this issue has been resolved internally. This solution will be available in a later release of the engine. Until then you could try launching VR mode with the VR preview with all other windows closed. I hope that this information helps.

Make it a great day

When is the low-rez issue going to be addressed? Everytime I build out a 64-bit Windows package for VR (Oculus), and I jump into VR mode in the game, I get this TERRIBLE low-resolution mode. Executing console commands do nothing, it’s like it’s stuck at “HMD SP 60” and won’t leave it for anything. I don’t see this problem when I’m using the VR Preview (with all tabs closed). I only see it in the final, built package. My game’s progress has ground to a standstill. It’s ready for release, except for this singular problem.