4.8 Preview 1 - Landscape Grass Population Crash

Not 100% sure if it is only with my existing landscape and landscape material, but if I’m using my existing landscape and level. But populating grass in my existing level’s landscape crashes. Tried with a new landscape and level, while it isn’t nearly as complex as my original material, it seems to populate fine.

When it is compiling shaders in my existing landscape and material, it will get to maybe 50% complete, grass will be where the shaders have finished compiling, but once it gets to a certain point the editor will crash.

I’m having the exact same issue, it seemed to get further along when i deleted my DerivedDataCache, but still crashed before completing.

Also, now that I’ve “saved” my landscape material changes rather than just “applying”, I can’t even open my project since it starts compiling shaders as soon as it loads up, and then just crashes 10 seconds later.

Change your default map in your config ini file so you can load the project and revert your changes.

Thanks, I just deleted and re-cloned my project since it was a copy of my 4.7 project anyway, but I still haven’t been able to get the new grass system working :frowning:

I managed to get the grass populated on my terrain by making the changes to my landscape material with no landscape in my map yet, and then re-importing the landscape.

I ran in to another issue here though as I can’t seem to assign layer info or import my layer info heightmaps in the new landscape tool (that just crashes the editor as well). I had to import my landscape from the heightmap by itself, and then assign the weight blended layers and import my layer info maps one at a time.

This could be what solved the foliage crash issue as it only had to build the grass fields one layer at a time this way. Since I can’t import my landscape with it’s weight blend layers on landscape creation, I can’t really tell.

Hi guys,

I’d really like to track down the cause of the crashes and get them fixed for 4.8. Would either of you be able to send me a project that crashes when you add grass to your existing landscape material? Or do either of you have a log file (in your project’s Saved/Logs folder) from any of your crashes?


Attached is a new Logs folder containing the crash as I have been able to consistently produce. Happens even if I don’t have any meshes in the Landscape Grass object. Logs Folder

Unfortunately won’t be able to realistically upload my project files unless I get use of someone else’s connection with a not so limited upload bandwidth.

Awesome, that log provides me with exactly what I needed. It seems to be crashing for components with XY offset maps which I hadn’t tested. I’ve filed a ticket as UE-15252 and I’ll try to get it fixed in time for 4.8 preview 2.

Thanks for the bug report.

Thanks so much. I’m looking forward to the next build if it gets that update. Testing 4.8 preview as much as I can, because the new features are something that is extremely handy for my natural environment that I’m making my own assets for.

This crash was fixed today and should be in preview 2. The fix is here if you are using Github.