Download

[4.8 -> 4.9] Light only casts shadow when mesh selected in editor

I updated a simple project from 4.8 to 4.9. The only issue I got is, that a spot light doesn’t cast a shadow of one mesh anymore. The spot light is inside a stove and should cast a shadow from the grid from the stove.
At runtime the shadow isn’t cast only when I select the stove mesh in the editor. That’s strange. How to fix that?

The spot light is behind a glass material, maybe I have to enable some “translucent shadow cast” option somewhere?

I use dynamic lights only. All lights are moveable, static lights are disabled.

In 4.8 it worked…

What if you remove the spotlight and add a new one in?

Same problem.

Same problem here, only cast shadows when I select the lightpoint. But the rest of the scene works just fine.

Good to see I’m not the only one :smiley:

check the material glass with both sides and will be all OK

Yep, that’s it. Thank you so much :slight_smile: