4.7 preview5&6 bug? - IOS build fails

The IOS build always fails with these errors:

link text

Howdy ,

Thank you for reporting this issue. I am going to need a bit more information before I begin investigating. Would this be a previous project that has been converted into one of the preview builds? Would you be using Package and Deploy or Launch On when you are seeing this error?

Would you be able to replicate this issue on a blank project or does this only occur on the project that you have been working on?

Any additional information would be greatly appreciated.

Thanks and have a great day!

Thank you!This project is made with an early build(4.6.1).And it packages well in 4.6.1 and 4.7 preview 1 2 3 4.I just tried package IOS option not the launch.

I have just tried a quick repro of the issue and have hit no errors. I am using the new preview 7 version of 4.7. Would you mind giving that a test and see if that has cleared up any issues that you may be having?


The 4.7 preview7 fails to build with almost the same errors…
Finally,I have found that maybe there is something to do with one asset for these errors:

MainFrameActions: Packaging (iOS): UE4Editor-Cmd: [2015.02.13-18.47.42:296][ 0]LogCookCommandlet:Warning: Package /Game/SpellSystem/System/SpellStruct supposed to be fully loaded but isn’t. RF_WasLoaded is set
MainFrameActions: Packaging (iOS): UE4Editor-Cmd: [2015.02.13-18.47.42:297][ 0]LogCookCommandlet:Display: Cooking /Game/SpellSystem/System/SpellStruct → E:/Unreal Projects/TopDownGame/Saved/Cooked/IOS/TopDownGame/Content/SpellSystem/System/SpellStruct.uasset
MainFrameActions: Packaging (iOS): UE4Editor-Cmd: [2015.02.13-18.47.42:298][ 0]LogWindows:Error: Windows GetLastError:
MainFrameActions: Packaging (iOS): UE4Editor-Cmd: begin: stack for UAT

And I tried to save that asset and fails with the following log:

EditorErrors:Warning: Warning Asset ‘E:/Unreal Projects/TopDownGame/Content/SpellSystem/System/SpellStruct.uasset’ cannot be saved as it has only been partially loaded

I tried restart the editor but still cannot save that asset,I tried opening and compiling all the assets referencing this file,failed to save either…

I do not know what to do…Thank you very much!

Have you tried to open a new project and transfer that asset into the new project? This may allow for the asset to open so you may be able to see what is occurring.

In fact,I can open that asset and edit it,but just cannot save it.

After I reopen the asset in 4.6.1 and resave it,the above error hasn’t appears till now.However,here comes another issue.I have a base bluprint,and when I create a child blueprint based on it, any time I add any nodes after the “parent:construction script”,it crashes immediately I compile the child blueprint.And this also causes the package failure.

Now I trie to package but it returns with errors for unknow structure…I have trie many ways and still cannot successfully build like the 4.6.1 or 4.7 preview1 2 3.The struct issue has driven me mad.I hope you guys will fix it in the next preview…Thanks very much!

Hey ,

Would you be able to share your project with me so that I may be able to test this issue on our internal build? You can send it to me via a private message through the Forums. Here is a link to my page: https://forums.unrealengine.com/member.php?4890-Sean-Gribbin

You could even make a sample project where you are able to recreate the issue if you would like.


Sorry for the late reply.Things get very strange if I migrate the issued file to a blank project,the error never occurs…I don’t know why…

After further investigation,I found that if I migrate the level and change the world settings’ gamemode to myselves,the package fails with the same error…Finally,I am sure that there is something wrong with the game mode…

And I have sent you a link as a private message,please test it for me thanks!

Thank you for sending over your project, I was able to test the issue and I am unable to package the project for iOS. Would you be able to attach your build failed logs to this post so that I may be able to compare them?


link text

Howdy ,

Thank you for the additional information that you have provided. I have entered Jira report UE-10708 into our bug database so that the issue may be addressed in a future release. I will be sure to keep you updated when i see any news regarding this report.


Thank you!Now i am sure the issue have something to do with the file being partially loaded,
these posts have the same issue with mine:

Hi ,

I have just checked in on the issue that was related to this post and There is a slated fixed implemented into the 4.8 release version of UE4. I am unsure as to when this release will be made public but the fix is in.

Thanks and have a great day!

Could there be a quick fix for that?Because of this big BUG,I cannot package my game any more…

Could there be a quick fix for that?Because of this big BUG,I cannot package my game any more…