[4.7 Preview 4] Missing navmesh data from sublevels navmesh bounds volumes after loading level


I’m having issue with navmesh data from sublevels navmesh bound volumes not being loaded after map reload.


  1. create empty persistent level and sublevel

  2. add floor (static mesh or BSP) to whichever level

  3. add navmesh bounds volume to persistent and sublevel (dont overlap volumes)

  4. make sure that navmesh data is generated by both navmesh bounds volumes

  5. save map and reopen it

  6. enable navigation data visualization and observe that navmesh data generated from sublevel's navmesh bounds volume is missing. Navmesh data from persistent navmesh bounds volume is just fine.

Tested on Binary 4.7.0. Preview 4 and code commit 56fb443

Hi TheDrunkenBunny,

I just tested this in 4.7 Preview 4 and was not able to reproduce this. How are you enabling nav data visualization? Console command, or Show Navigation flag in viewport? Does this happen in a new project, or only your current project?

Hi ,

I’ve attached “clean” test project based on 4.7 prev4.

In my case it doesn’t matter how you enable navmesh drawing (‘P’ hotkey in editor, showflag.navigation, show navigation).

I recommend you to load provided test map TestLevel_P. Enable navmesh drawing, hit build button and then simulate or save and reload level. You shoud see that navmesh data generated from “loose” navmesh bound on sublevel dissapeared.

Hi again,

I can see bug happening as you describe in project you sent me, but I still cannot reproduce it in a new project. I think I may be missing a step or a setting somewhere. Can you run through process in a new project and make a note of each step for me? Thanks!

Hi ,

I do nothing special creating test project. I open 4.7.0. Preview 4 through Laucher and create new project.

Here’s link to video presenting process: link text

Hey TheDrunkenBunny,

Thanks for video! I was able to reproduce this behavior in 4.7 Preview. I’m still not certain why it worked in first project I tried, but my process was slightly different so I’ll keep looking into it. For now, I have created a bug report for developers (UE-8534) and I will let you know when I see any updates on it. Thanks again!


Just an update that this bug has been fixed internally and should appear in a future release. Thanks again for report!

Hi , can you point me to changelist it was fixed in? I need to cherry pick it for my project.

Hey dzeligman,

I double checked bug report, and it looks like it was closed because it’s no longer reproducible, so we don’t have an exact CL for it. I would expect this to appear in 4.8, though it may be fixed in a 4.7 hotfix.

There is a separate bug in which Nav Meshes are not visible during PIE that has not yet been fixed, as well, in case you decide to test in a newer build.