4.7 Parameters not changing BP.

I Have this BP and worked fine along the versions of UE. Started on 4.2 and this last build is on 4.6.

But when I tried to use it on 4.7 I noticed some issues.

1 - Only the first change on parameters have effect. If the parameters is setted on Construction Script, they not fired again on change. You can check this by cheking and unckeking the “Show Widget” checkbox of my BP, or changing “global angle” parameter.

2 - Older versions has “ReturnNodes” even if they are “empty”. But In my BP, they still there. If I add one output just for test, and then remove it, the return node is gone. Look at Set Speed Function, on Construction Script.

3 - I have an Variable called Skydome material, started on Construction Script. I Create an Dynamic material Instance, then set this var with return pin. On older versions of UE4, I can change the parameters of this var at any time over event graph and the material is update. Now on 4.7, every time if I want to change some parameter, I need to use “Set Material” on SkyDomeMesh. This have a huge cost on tick. For more details, Look the function “UpdateSunDisk” function and where I Create the variable “ConstructorSkyDome”. I think this is the error. Because I copied the way of skysphere use it.

I thing all this is because some residual of older versions, because other blueprints works fine on 4.7 (for me).
But i really cant redo all this BP. Its Huge.

Hey reneberwanger -

Thank you for your report. We have seen and fixed this issue. It has to do with values getting hard set in the Construction Script and not allowing new values to be inputted. The fix for this issue should be coming with the next Preview build of the engine. In the meantime, here is the commit for the fix, https://github.com/EpicGames/UnrealEngine/commit/04065ba706d60c2fa0f8456eb1da0679e38a4e36

Thank You

Eric Ketchum