4.7 p5 unable to translate/rotate static parts blueprint

Since I installed 4.7 preview 5, I notice the blueprint editor has an issue when I try to transform static meshes that are part of the blueprint. When translating or rotating a mesh who’s mobility is set at “static”, using the transformation handles in the viewport doesn’t influence the mesh. The object’s appropriate transform values do seem to change however. Closing the editor and re-opening it result in the display of the correct transformation. When the part is set to “movable”, everything seems to work fine.

Hi miliem,

Does this occur in a blank project with no additional content or is it limited to a specific project/mesh?


I updated to preview 6 and the issue seems to be fixed for some of the meshes. I can interactively move some parts around, but some remain unaffected. It seems a bit random which parts have the issue. It seems to be an issue only for imported meshes in already existing blueprints. Importing the meshes anew in an empty project doesn’t seem to cause the issue. I do however notice some issue with dynamic shadows cast by stationary lights since preview 6. Shadows seem to be unstable and switch on and off.

What specific steps are you taking that reproduce this? Currently I have been unable to see this effect on my end.

Hmm, i think I misinterpreted some blueprint functions, causing the issue. I use a construction script and several exposed variables to manipulate the position and orientation of several of the components. I do this by using the SetRelativeLocation and SetRelativeRotation functions in the construction script, assuming that relative meant ‘relative to the original position.’ I guess I was wrong there, and I should AddRelativeLocation and Rotation to position objects in the blueprint viewport as well as being able to manipulate them from within the editor.

I guess manipulating individual components in the blueprint editor fires the construction script as well and resets the position of the objects every time. Is this intended behavior? I assumed the construction script was only fired for instances of the blueprint. The confusing thing now is that the transformation values in the blueprint details are changing while there is no visual effect.

I just updated to preview 7, and some things seem to have changed. I can move around objects in the blueprint editor again, so that’s great. However, I don’t seem to be able to set positions using the exposed variables and the construction script more than once anymore. When I compile the blueprint and create a new instance in the editor, I can set the variables once, correctly changing the positions of the appropriate sub-meshes, but when I modify the variable afterwards, nothing happens anymore. I do see the construction script fire in the BP editor, but it doesn’t result in any modified object positions.

Can you show me a screenshot of what is occurring? It sounds like what I would expect depending on what you have set up in your construction script. Every time you move an object it is technically destroyed and rebuilt, which causes the construction script to fire. If you have hard values set in your construction script it may be overriding any changes you make because you are telling it “when created, do X”.

I created an example in an empty project and made a blueprint consisting of a pile of blocks. I uploaded a number of screenshots. The blueprint shows the construction script for the pile of blocks. I created two variables (test1 and test2) that have been exposed outside the blueprint. The editor initial, editor_moved and editor_moved_back screenshots respectively show the newly placed instance of the blueprint, a version where I edited the test1 and test2 variables to be 100 (and where the blocks did move accordingly) and a later version where I put the test1 and test2 values back to 0 (but where the blocks didn’t move anymore). In older versions of the editor this always worked fine. Now I can only move elements once after creating them.

I tried this originally using the SetRelativeLocation blueprint function, which also worked in older editor veersions, but in that case the blocks seems to collapse onto the origin. This would be logical if the variables overwrite the transformations set in the blueprint editor. However, the blocks won’t move when changing the variables in the editor, while I would expect that they move to the position provided.

Unfortunately I haven’t been able to reproduce the error on my end. Do you have any other steps I can take to try and recreate this?

I created a little new example project showing the issue in engine version 4.7 preview 7 example project. I created two blueprints consisting of two blocks. One has a construction script setting the relative location of the second block using an exposed variable. The other block has a construction script adding to the relative location of the second block. I tried exactly the same setup in 4.6.1, and everything worked as expected. In the 4.7 p7 version, when changing the variable values from inside the level editor, the SetRelativeLocation version does nothing, while the AddRelativeLocation version only works once.

Hi miliem,

Are you using the launcher version of the editor or a source build from Github?

I use the launcher version

This seems to be working in Preview 8 as I would expect it to. Can you update to Preview 8 and see if this is working for you?

Indeed, I just updated to preview 8 and it seems to work fine again. Thanks for the help!

Hi miliem,

I am going to mark this as answered for tracking purposes. I am happy to hear it is working for you. If you experience this error again, please comment and let me know so I can continue attempting to reproduce this on my end.