Download

4.7 No Oculus VR Preview or VR mode fullscreen

I downloaded 4.7 onto my mac and I now cant seem to play any level in VR mode with my Oculus DK2 by - launching - hitting fullscreen mode. VR preview is also greyed out. Everything was working fine in 4.6 and I’m not sure what to do. I’ve rebooted the mac and still nothing. I saw in another thread someone was able to fix the issue by reinstalling the Oculus drivers but I just wanted to check first this wasn’t a mac issue.

Same problem here, is there a fix?

VR Preview is greyed out on mine in 4.7 as well. Going to reinstall drivers and see if this fixes it.

Fixed launching the applications fullscreen by removing the preferences for the specific app from the user’s Library folder.

Reinstalled runtime and re-updated firmware and the VR Preview is no longer greyed out in 4.7.2. However, FPS in the VR Preview is about half that of a Standalone play, but that’s a separate issue I guess!

I too had the VR preview grayed out on first run, even with the latest oculus runtime & sdk installed. Looked at oculus config utility was unresponsive. Happily a simple rebooting of the PC fixed it all up.

I haven’t benchmarked 4.7 Standalone yet, but VR preview for me is surprisingly much smoother/faster for my test scene with higher scalability settings than in 4.6.1 Standalone with lowest settings :smiley:

Reinstalling the drivers worked for me as concern the VR Preview greyed out, but even if now VR Preview is active, I cannot launch the app because all I got is a black window.
What is the expected setup? Rift in extended mode? Primary display on rift or mac?

I’m having the same issue on mac. I’m on 10.10.2 Yosemite, 4.7.2 Unreal, latest Oculus runtime, …I’m using the DK1 not DK2. When running the VR Preview all I get is black screen. Stand alone won’t go into stereo mode or respond to HMD rotations.

I managed to fix the issue by downloading the latest Oculus Runtime & SDK then simply rebooting my Mac.

Fixed by re-installing Oculus runtime, rebooting and disconnecting my second monitor.

Bump!

Any news on this? Having the same problem, VR Preview is just black. I love Epic and the Unreal Engine and I’m eager to start developing VR content but I feel Mac users are constantly struggling to make things work, which is immensely annoying and a creativity-killer!