[4.7] F11 Fullscreen editor border black / white

In the 4.7 release, if put the project in fullscreen with the F11 in the editor, the top & left border is black and create a blur effect.

Hi ,

Could you post a screenshot showing exactly what you are talking about?

No, because is a private project and is only a line, but is a black line at the top of the game and other at the left side.
Only at press play, and at start flickering after press start and after 2sec is complete black. (a 6px of width).
Some object cross the line.

Looks like a bug with the HUD
Because after disable the HUD in the viewport and press play, don’t have line.
If add a simple UMG Widget to the viewport with a text and image, you get that.

I haven’t been able to reproduce this behavior in-house and without some sort of repro we will not be able to fix the issue. Can you try to reproduce this outside of your game in a new 4.7.0 project?

1º. Create new Topdown BP project.
2º. Create a UMG HUD with a text.
3º. Add in the player controller of the topdown the widget to the viewport.
4º. Press play, press F11 bump, the error/bug/problem (but with a white lines)


Hi ,

Thank you for the report, I was able to reproduce your issue. I have created JIRA UE-11109 and our developers will be investigating the issue further.

I’m unsure of a workaround at this point, but it seems to be confined to the TopDown template.



So wait a minute , i got here for the same issue got the 4.7.3 Just downloaded a few days ago. Yes i started with topdown and ended up with flight mechanics. (Copy/paste from little spaceship project for Basic movement) and now you say that the problem is topdown? So i should start over , AGAIN??? OMFbuuuug when it will be over? I’m a little bit tierd of bug bug crash start over… WTF! Since my project start over from udk (like 1 yeah ago) to make it ue4 , now i dont think i will ever finish it. Lol I’ll keep it like this Till Fix if it doesnt get fixed I’l release it in this conditions writing sorry guys it Unreal’s problems not mine … :frowning: btw note that i made 2 questions in HUB 1st Answered my self. The 2nd no answers in 20 day’s so yeah thx for the support y’all … but What do you want udk was beta Even after ue4 so think this is like alpha.

Hi Sgt. Wolf,

This is an very niche bug that will not effect your packaged game. It is confined to the editor itself and is only visible with a HUD in place while using the F11 option to make Play-In-Editor fullscreen.

With that said, you may have better luck getting the community to respond to your post if you maintain a professional demeanor. Also, it is sometimes better to ask game concept and how to questions on the Forums.




Finaly a Good thing since it has wath it has. Sorry if you Take it on personal but as i say first I’m a little stressed by how this go udk was beta crash on crash now ue4 is the future and id like to make my things work but it’s like a girl VERY sensible at some Point it crash or action stupid so after 30 trying and trynig end’s up you reboot and works. And since Even my questions are ignored I can say i have all the right to be mad as hell. So yeah ill continue the hard way Hours of Google for minuts of work. you Save your self only for the fact that when it works the engine is realy a beast. But lol…

Hi ,

I just wanted to let you know that this is now fixed in our latest internal build. You should see this working correctly in a future update.



Thanks for your time and your help!
I’m waiting for the 4.8! :slight_smile:

This continue broken in the 4.8 P1…

I’m waiting months for the 4.8 but the fix don’t is here, where is ??

Hi ,

I’m sorry that this is not fixed in 4.8. I verified the JIRA as fixed in changelist 2505032 but as of the 4.8 Preview 1 (which is 2536902) it seems to have regressed. I have reopened the JIRA report and our developers are going to be investigating this again.



I need fix to the 4.8 release please is needed.
I don’t have others 4 months to spend waiting.

This isn’t present in a packaged game and is only an issue when using the F11 view option while in the editor. This isn’t a show stopping bug, you should be able to continue working on on your project while a fix is being looking into.

But i can’t test the game in the editor in full screen, i need to package and compile the game each time i need to check the HUD and menus ?
That don’t is the best plan.

The bug isn’t present while using Play in New Window or Standalone Mode. You can go to Edit > Editor Preferences > Level Editor > Play > Then set the window size to the full size of your monitors.

Would that work for testing purposes?

Thanks for the tip.