4.7 degenerate tangent

hello,
when i import a fbx object to 4.7 i get the alert “objectxy has degenerate tangent bases which will result in incorrect shading.”
ia also can see the issue based on this problem (dark edges on the mesh)

But in 4.6 i have no problem with this fbx object.

Hello schweinerüssel,

When you are exporting your .FBX object, what are the settings you have checked/unchecked for the geometry section?

For example, my default settings are:

The import settings you have when importing into the editor could also be what is causing your issue.

If you would like, you can share with me your .FBX file, if it is not too large, and I can test it here on my end. To do that you just need to Private Message me on the forums with the attached .fbx file in a zipped folder. If you are not comfortable with this approach, no problems, we can try to troubleshoot in other ways! :slight_smile:

Thank you,

Andrew Hurley

Hello again schweinerüssel,

So I grabbed your .FBX file you sent via Private Message to me on the Forums. Before importing your Mesh into the Editor, I opened it up in 3ds Max and noticed a couple of things.

First, if you are attempting to make this model to scale then you will need to re-size your mesh to something much larger. Secondly, I suggest going back through your mesh and cleaning up some of your faces with the degenerate tangents.

I attempted to import your mesh into 4.6.1 build and was unable to do so. Every time I tried, the importer would reach 75% completion and crash. I checked and unchecked multiple settings with the export/import options, all with the same result. I am not sure what I am doing different than you, but you mentioned it worked fine in 4.6 which I am not getting.

I then tested importing your mesh into 4.7 (preview 3) and was able to do so, but it presented me with the error message you mentioned. When taking a look at the mesh after having it imported, there were not many shadowing errors I noticed.

My suggestion to you would be to break up your mesh into a few sections and make sure all of your pieces of geometry are cleanly modeled and have been unwrapped accordingly. Sometimes when you have a very complex mesh with a broad range of various angles and faces, the editor can have troubles producing light information for the entire object.

Take a look at the Documentation page for FBX Static Mesh Pipeline and the FBX Import options. Both will give you detailed information on how and why when exporting/importing Static Mesh actors for the Engine.

FBX Static Mesh Pipeline

FBX Import Options Reference

Cheers,

Andrew Hurley

In 4.8 the option has been exposed in the Static Mesh Build settings to disable MikkTSpace.

This is fixed with CL-2519373.

When can we expect to see new build?
I have also the same probl, i just made a box in maya scaled to fit the floor scene and exported as fbx, and i cant get rid off the error msg?!
thx

There is no “official” release date yet for the final 4.8 build, but you can expect the previews to start soon for community testing though.

Since the Previews can still be unstable and are not recommended for development purposes you can expose this yourself by going to your ConsoleVariables.ini.

add the line: r.MikkTSPaceOptional=1

or you should be able to bring up just the console window and toggle it on that way.

This will enable the check box in the build settings. This can then be disabled in the Static Mesh Build settings.

][1]

Thanks for a quick reply, i have a small req could you plz check this fbx and tell me whats wrong or what did i do wrong, thx

cheers

More than anything the UV needed to be cleaned up. Opening it in 3Ds Max and just applying a Flat mapping to the faces resolved the issue.

Typically the MikkTSpace difference will affect more those meshes with Blender and XNormal since this is something that those specifically use.