4.7.6 Packaged Build - Open Session not working


We’re currently working on a FPS game with a cooperative mode.

I built the full logic of opening / joining session and actively tried it in packaged version (full Blueprint networking, some C++ elements in the project, nothing related to network).

Worked all good in Editor and Packaged build. Since today, it only works on Editor mode. In Packaged Build the Open Session always fail.

Only thing that changed since my last packaged test is the version of Unreal I’m working on (from 4.7.1 to 4.7.6).

Maybe I’m missing an important piece of the networking setup in packaged mode? Since it worked so far I’m not sure what to look for.

Thanks in advance for your answer.

Hi Yun-Kun,

Here is another thread which addresses a similar problem. Have a look and see if it helps at all.

Good luck!

Hi :slight_smile:

Thanks for your answer but I didnt find the solution in your thread so I created a blank project using C++ and recreated session from scratch. I found my problem.

We lost some “SubsystemNull” dependencies in our versioning / version updating process.

We figured it out and added the needed dependencies in our C++ build.

You can consider the problem solved for your tracking system.

Thanks again for your answer.

Bye :slight_smile:

hi there, can you explain it more specific please?
We ran into the same thing

In order to get the networking running you need to add some dependencies in your CS Build. We apparently “lost” some of them while updating in the newer version of unreal. Simply writting them back again made it work.

Hey there ,

In your Build.cs file add the below code:

if ((Target.Platform == UnrealTargetPlatform.Win32) || (Target.Platform == UnrealTargetPlatform.Win64))

            //if (UEBuildConfiguration.bCompileSteamOSS == true)
            //    DynamicallyLoadedModuleNames.Add("OnlineSubsystemSteam");