[4.7.1] - Engine appears to causing a lot of CPU Stalls

Hey Guys,

I am noticing that 4.7 is having some issues with performance. I just checked across two projects and noticed that the performance shouldn’t be as bad and appeared this way through doing some profile. It did jump drastically from 4.6.1 to 4.7 and still is an issue in 4.7.1. I am noticing that even on an empty level, the engine is consuming between 6ms-8ms of time and I checked and the CPU Stall - Wait For Event is through the roof. Let me know if this is a confirmed issue in the engine and how to go about solving this problem. Thanks again!

I am also experiencing this, 4.7.1 is barely usable for me.

CPU constantly jumping between 90-100%, tooltips and everything within the editor are massively slowed down and jittery. This issue is only there when using 4.7.

Hey Dealman! Yeah, I’m not sure what’s causing it. I’ve seen my card struggle and I have a GTX 980 in my system with a scene that shouldn’t be causing that much load. But the stalls were frequent and that’s what’s bottlenecking things, just not sure what the cause is. I noticed when running my game outside the editor, I got the same thing. 4.7 was definitely a rough release but the devs at Epic are working hard to try and get the numerous issues resolved. I don’t know if I’ve seen this one pop up on the threads recently but since I was right in the middle of Profiling during my upgrade from 4.6.1 to 4.7.0, it was pretty easy to spot considering there were no functional or code changes. I know they have a 4.7.2 and a 4.7.3 release planned so I’m sure they’ll work on it but hopefully someone from Epic can look into further.

Same here with 4.7.2.

Do you guys have by any chance any videos (wmv etc.) or media textures created by them in your project? If yes I think I know what is causing all this CPU usage.

@Roccinio: That’s a negative; it lags this much even with a default scene. I’ve been trying to find the cause but I’m all out of ideas. I’m hoping a future patch will remedy this issue, I might even try to re-install it I guess…

I am having a cpu and gpu meltdown when i enable videos in my project and i thought that this might be the cause for you as well. When they are enabled I get 12 fps with an overclocked GTX 980 ! (lol) . But i least i have something on screen. Your situation is even worse than mine i guess…

That’s pretty rough. I also have a 980 primarily running stock but it’s not lagging that bad. An no videos for me as well, this happens on a bare project for me. If you profile your game with stat startfile and capture some data, you will notice, at least I’m guessing, that you’ll see CPU Stall - Wait For Event sucking up a lot of time. In 4.6.1, one of my base projects with no assets in it went from 2-3ms to over 16ms when upgrading to 4.7 which was pretty crazy. I haven’t tried videos quite yet and have been doing my cinematics inside Matinee but I’ll probably wait that one out till at least 4.8 :slight_smile:

Hey John! Yes, I am rocking a EVGA GTX 980 SC in my machine. The other specs are Z97, Devils Canyon 4790K and 32GB of DDR3 1866Mhz RAM. Thanks for helping out!

Hey guys, I’m looking into this issue. Are you all using 900-series GPUs?

It sounds like Roccinio’s issue is different, but if the rest of you are seeing crippling performance issues on such powerful computers, something’s definitely going wrong. I’ll get back to you when I have more information - let me know if you find out anything.

Edit: As a side note, can you try removing the light source in a scene to see if that changes anything? User TSDREX says in this thread that Point Lights were causing substantial slowdown on his 970-equipped computer.

Hi all,

I’ve posted a thread asking same question… I’ve found out myself that some reason point of light is lagging certain area. One way to stop this is ether Remove point of light Or like me Turn off the shadows in point of light setting it’ll make it lag free.

I have no idea why this is happening because most of us have decent Graphics card 970/980. i’ll try to report this on the forums hopefully will fix it.

TSDREX.

GPU 1: MSI GTX 780
GPU 2: ASUS GTX 560 Ti DC2 (Used as dedicated PhysX Card)
CPU: i5 3570k
RAM: 16GB DDR2

Will try the suggested solutions and see if it helps.

Edit:

I just updated to 4.7.2 and I haven’t run into any major performance hiccups as of yet. Will report back if I do.

Edit2:

While the majority of the issue seems to be resolved for me with 4.7.2, I am still getting rather significant slow-downs whenever I try to drag a node to another.

This happens all the time, not matter the scale of my project. Don’t recall having this issue before 4.7.

Edit3:

Manage to find what was causing my performance issue; it’s the new tutorial system.

I went into Editor Preferences → Tutorials and changed Startup Tutorial to None. Suddenly CPU usage dropped tremendously and I am no longer getting lag spikes when using graphs.

Hi MC Stryker,

It seems we have different causes for different people with similar GPU’s experiencing a similar issue. To recap:

  1. Roccinio’s (GTX 980) experiences CPU
    lag when enabling videos in his
    project
    2. Dealman (GTX 780 GPU w/GTX 560 dedicated physics card) experiences
    CPU lag when tutorials are enabled
    3. TSDREX (GTX 970point) lights or shadows with point lights are
    causing a lag
    4. MC Stryker (GTX 980) cause unknown.

In order to move forward investigating this issue, MC Stryker, do any of the things suggested resolve your issue? Have you determined what, if anything causes your machine to slow down?

Let me know,

Thanks

I do not think that this has anything to do with nVidia gpu’s. I had the exact same problem with an 290x. For me it looks like a problem with unreal offloading all gpu calculations to the CPU as I have shown in my post in the answerhub. When I enable my videos my CPU usage nears 100% and my gpu usage is almost non existent .

Hi Roccinio,

Thanks for the feedback. I’m trying to determine if we need to generate a separate bug report for each or if they are part of the same bug. You wrote: “it looks like a problem with unreal offloading all gpu calculations to the CPU as I have shown in my post in the answerhub.” -This appears to be a separate issue and I did not find this as an issue you have already posted so, unless I missed it, will you create a new post and provide steps to reproduce it? -Thanks

Hey Steve and thanks for the response!

I am going to try and turn off shadows on my directional light and try to disable tutorials to see if that fixes it. I’ll get back to you shortly with an update. Thanks again.

Hey Steve, so none of the fixes unfortunately fixed it for me. I tried setting the startup tutorial to None and even disabled shadows and it didn’t seem to resolve this. Keep me posted on if there is anything else to try. Thanks!

BTW as a heads up, I’m using 4.7.2

Hey Roccinio. I think Adam didn’t hear back from you on your Paper2D thread. Just was looking at it and noticed his response at the bottom so wanted to give you a friendly heads up.

@Roccinio I am using media textures and am having the same issue. CPU usage is in the high 70% with nothing running. Do you know what the cause was or how to fix it? In 4.7.1 and 4.7.2