4.6 and oculus what changed?


I saw somewhere at some point that there were some VR updates with 4.6.
I’ve been running it with my current project and I don’t notice any improvements at all in FPS or graphics.

In the lengthy blog post at unreal announcing the update with all the changes VR wasn’t mentioned at all. Why is that? Were those improvements not in this release? If there were improvements what are they? Anything anyone recommends changing in my project? I tried increasing my hmd sp number from 110 to 130 and it was way under 75fps. Tried direct to rift and that is still giving me lower FPS than extended…etc etc.

How will we ever be able to run at 90 fps in the next oculus? is everyone just abandoning unreal for VR development?

thanks for any info!

set all scalability settings to the lowest and you should get 100+ fps on average hardware.
Scalability reference

Use the execute console command node for each of these:

sg.ResolutionQuality 25

sg.ViewDistanceQuality 0

sg.AntiAliasingQuality 0

sg.PostProcessQuality 0

sg.ShadowQuality 0

sg.TextureQuality 0

sg.EffectsQuality 0

I’m getting 220+ fps on my GTX970, but it obviously depends on the game and the hardware. Extended mode performs a little better than direct mode.

Hey treebykooba-

Is your Oculus set to Direct HMD or Extend Desktop mode? Also what command are you using to enter Oculus mode, is it the “stereo on” console command or are you using Alt+Enter? Is there any performance change if you use the “hmd sp #” command to change the screen percentage? Let us know if there are any other steps you use in testing the fps.



4.6 includes support for the new 0.4.3 Oculus runtimes, which are faster internally in Direct Mode. That driver revision also makes Direct Mode far more stable! It was in the release notes under the VR section, as it’s now required to update to 0.4.3 to run UE4.

Internally and externally, there is a lot of content that runs at 75 Hz, and even at 100+ Hz consistently. All the demos Oculus showed off on the new Crescent Bay were running UE4, so it’s hardly abandoned :slight_smile: The problem is that you have to be very careful about what you enable and disable in the rendering feature set in order to get your performance up!

For lots of good info, check out our talk where we show how we made the Showdown demo run at 90 Hz at a high resolution:

We’re working on making those settings listed in the presentation a preset for starting new projects, so that you can have a nice, performant base to start from.

Thanks for all the feedback. I’ve had all my scalability settings very low for awhile but i keep vsync on. with vsync off i was getting like 120FPS but it was too choppy.

i’m hoping to be able to use at least hmd sp 130 now but still can’t get there… I will try to mess around in direct mode more. I’d been using extended as that was the only way to get the 75fps before.

do you all know if we should upgrade to the new SDK that just came out? or with this version (4.6) of unreal is the .4.3 SDK better?


Something seems off for me after having updated to firmware 2.12 and 0.4.3 drivers. My old Unreal 4 deployment ran at 75hz locked before but now it’s running at about 35-40hz… This was not rebuilt code, still based on Unreal 4.3.1.

My new build and deployment (Unreal 4.6) has the same performance penalty as well.

Thread discussing it: UE 4.6.0 and Oculus 0.4.3 huge bugs - VR and AR Development - Unreal Engine Forums
Answerhub question:

Same here, my demo run in 0.4.2 at 90-100 fps now 80fps and sometimes i can’t get 70fps and vsync drop to 37.

I have similar issues, very bad performance in Direct Mode since the 0.4.3 runtime. Could it be related to Windows 7 and AERO?

Posted more details here:

Terrible vignette implementation in 4.6. I think they’re reducing it for the next release.