4.5.1 Serious rendering issue

4.5.1 Serious rendering issue

Now i have a major problem ongoing, Ive updated all the test scene’s to UE4 4.5.1 and can’t go backwards but when i open my maps with 4.5.1 the following is what i get, It’s all Kinds of messed up!.

When loading my old landscape scene’s to update for my asset pack which was to sent of to Epic UK today (not going to happen now!) this is the problem i get. Should add the Epic landscape example is also doing the same thing.

Please help, i need to finish these scene’s or i can’t send of my work. AGGGHHHHHH. Can people check to see if they get the same issues with 4.5.1. ALSO EPIC, HELP ME! AGHHHHHHHHH

Any chance you are using the birds from the landscape demo in your map? There is an issue with the material, specifically the vertex shader:

Ill check now, but ive also tried just a normal landscape tool scene with nothing but the landscape and related volumes and every single one the terrain material doesnt show or work (so cases a tiny patch of terrain does and the rest is missing. Try to change or edit the terrain shader and the whole editor locks up and becomes unresponsive, Editor wont even let you shut it down (have to go into task manger and force the app to shut. How did issues like this get passed by QA testing?

Another guy also stated he has the terrain shader issue with the racer game, but it’s effecting all my terrain based levels. And then theirs that weird graphics glitch shown in the video.

Need an immediate patch from epic today if possible on github.

Hi KingBadger3D,

Two things:

  1. Can you post this to AnswerHub in the “Bugs” Section with all relevant information along with a link to this forums post.

You will want to make sure to include information about the version of the engine you’re using (Source or Binary), is this occurring any projects other than your project, and is this a particular asset that is causing the issue (You can figure this out by going through the scene outliner and turning off assets until the offending object is located)?

  1. Looking at your Scene Outliner I can see the BP_Bird. With the release of 4.5 the material for this particle effect was redone. You will need to go into the M_Bird Material and change the Static Switch Parameter Values to be flagged as True.