[4.5.1] Crash when importing fbx

When I try and import my fbx in to UE4 it crashes with no error message. I have tried endless combinations of exporting/importing to no avail. Other fbx files import fine, so it’s something specific to this one. I have absolutely no idea what is going wrong here. Attached is the Max and FBX file.

Tried importing in to 4.4.3 and it imports fine so it is a problem specifically with 4.5.1

Hi Sailors,

Thank you for reporting this. This is a known issue that affects some FBX imports (UE - 3032). I’ve updated some notes and added this AH post to that bug report as well.

As a workaround you can import the mesh into UE4 by unchecking the “Generate Lightmap UVs” when the Import Options window is open. This is where the hitch is happening that is causing the crash. If you need/want lightmap UVs you’ll need to create them in your modeling software for this particular mesh or any meshes that are causing the crash to occur.

Once a fix has been submitted I’ll verify and update this post with any and all relevant information.

Thank you!


Note: click the eyeball in the top right of the import window and click ‘Show all Advanced Details’. Under ‘Mesh’, ‘Generate Lightmap UVs’ will appear.

I Have the same problem when importing my FBX.

I tried renaming and unchecking generate lightmap UV’s and I do have a second channel.

I have tried a lot of things but it just crashes every time :frowning:

Hi Zombie,

Would you be willing to share the asset (publicly via link here or send a link to me on the forums for the asset)? I can take a look and see if I get the same results and verify if this issue is the same.

Let me know.


Hi Tim,

I also frequently get crashes when importing models. Even in the latest 4.6 release. I’ve always struggled to get UE4 to open models which import fine in other engines.
There seem to be a lot of threads about this here but they just get closed down without a solution.

In fairness I think the models are “broken” to an extent - they’re ones I’ve downloaded from various sources and converted, so they’ve probably got dodgy UVs, missing textures etc. The worst problems also seem to happen on huge models which are a bit ridiculously big.

I think the point is though, the whole editor shouldn’t just crash when it gets a bad import… can’t the importer run in a background thread and catch exceptions and give meaningful error messages rather than just hanging/crashing the editor? That seems like a bug to me.

As I said these same models do import in other engines… A certain well known $1500 engine for example seems to be able to deal with all sorts of errors in the imported data and make sensible decisions to get the asset up and running, without crashing, spewing out errors or having all the materials missing. It would be great if UE4 could do the same rather than the go-to answer being “fix the source material”.

Thanks for looking into it :slight_smile:


I won’t argue that the editor should not crash on imports as that can be rather frustrating. I’ve not had any experience with Unity or CryEngine with how they import or any errors they may throw (assuming you were referring to one of those available engines :wink: ).

A lot of the crashes I have seen users report since the release of 4.5 have been related to the new method of auto-generated Lightmaps UVs during the import process. There were two reported issues related to auto-generated Lightmap UVs that would cause a crash. The way to avoid this was to uncheck the option to generate them on import (at the very top area) so that they are not generated and causing the crash.

This bug is high on the queue, but a fix has not been checked in as of yet.

If you’re able to import after unchecking this import option then this is a known issue. If the crash is still occurring with this unchecked there is something that can be looked into and see if I can get repro on my end.

I’m certainly not trying to dismiss any crashes as “fix the source material” especially if a repro can be found. It’s much easier for a developer to fix an issue if there is a solid repro that can happen with things other than a single mesh. If it’s just a single mesh it may be something that is corrupted or wrong with that particular mesh. Being able to use the same steps and recreate the crash with any variation of mesh makes it much easier to look and see where the root of the problem may be coming from.

That being said, if you have a set of repro steps for creating a mesh and getting the crash I’d be happy to look at that and see if I can help. :slight_smile:

I know you mentioned getting meshes from online resources. This is fine, but often times these will need to be adjusted to be “game-ready.”

Let me know and I’ll look into this further.

Thank you!


I had this problem with 4.6. Unticking the lightmap stuff solved it for now. (My model is not UVW mapped properly yet, dunno if that could be a problem too)

All .obj files created by MagicaVoxel ( https://voxel.codeplex.com/ ) freeze or crash UE (4.6) when imported. As suggested, disabling “Generate Lightmap UVs” worked.

This bug has recently been fixed and will be in 4.7. You can test this out with the 4.7 preview builds that are currently available via the launcher or once the final build of 4.7 is released.

The fixed CL is 2400339.

Thank you!


same problem here.
Error (crash) when importing FBX with LODs (xxx_LOD0, xxx_LOD1).
UE 4.7.6 + dx10 Gpu.
Crashes when message “Generating distance fields” … crash!

Importing the LODs individually = no problem

@Blackhole Bilbao

Can you post this as a new question. This isn’t the same issue that was fixed with UE-3032 when 4.7 released.

Thank you!