4.4 behavior tree editor how to disable focusing?


I don’t remember this feature from 4.3 and it is really annoying, i;m watching on certain part of tree and editor switch my focus and changing zoom. How to disable it? Just point me a line of code, please :wink:

Best regards


Hi Pierdek,

Are you talking about while debugging? As in watching the Behavior Tree while playing and the BT graph view is jumping around?

Yes, 7 characters needed…

Ok, found it:)

void FBehaviorTreeDebugger::SetNodeFlags(const struct FBehaviorTreeDebuggerInstance& Data, class UBehaviorTreeGraphNode* Node, class UBTNode* NodeInstance)

And the winner is:

Node->bDebuggerMarkBreakpointTrigger = NodeInstance->GetExecutionIndex() == StoppedOnBreakpointExecutionIndex;
	if (Node->bDebuggerMarkBreakpointTrigger)

Weird thing is because this jump should be enabled only when node is marked with breakpoint. So maybe this is a bug?

However it would be nice to have a checkbox somewhere in BT editor to enable/disable jumping.

After further digging I have found something interesting.

When I added new decorator that is always valid to a Root->Selector(here decorator)->Selector, the engine threat this decorator like breakpoint and always jump to him.

So, this is a bug or I still don’t know how to use Behavior tree editor. What do you think TJ ?

Hi Pierdek,

I’m sorry it’s taken a while to get back to you. This was a bug and it has been fixed in our latest internal build. You should see it in a future update.