Download

4.4.1 Hotfix Preview!

That did the trick! Thanks!

I’m not going to use the method above for getting 4.4.1 preview as I am not in a rush to get it, so don’t want the preview version, but thank you mint sauce for the help! :slight_smile:

However, the update downloaded this morning did break compatibility with the plugins I am using (rama’s nodes and substance), so I may end up reversing it and going with the backup version on my HD. I am almost positive this update that I downloaded this morning is supposed to be 4.4.1 and just didn’t update the version number (I have not heard of any other engine updates for version 4.4 aside from 4.4.1, so it must be), but if this is the update, it will probably be necessary to re-download it once they apply the version change.

For now it doesn’t matter to me, but I would like to hear an update from Epic on what exactly the update that was pushed to the launcher in the past 24 hours is if it isn’t the release of 4.4.1… No rush guys! I am just a little confused about this. :confused: :smiley:
FYI Epic: after the update this morning my version says it is “4.4.0-2237849” in the editor’s exe details.

I’m using 4.41 preview, works fine. Though I also noticed sometime yesterday that an update for 4.40 was avaiable and after updating I was still 4.40. Bit odd, didn’t break anything though.

Downloaded the 4.4.1 preview and everything works fine.

How do I package a direct to Rift app? My build only works with Rift in extended mode.

Hmm I don’t think I had to set anything special, worked out of the box. Just need to hit ALT-Enter to fullscreen. Works both in “Standalone Game” in the editor and packaged.

With the hotfix preview installed I no longer have to pause the service to get my game working. However I have the following issues:

  1. performance is the same as before in extended mode, but there is a performance drop in direct mode

  2. the positional tracking feels off on both extended as direct mode, anyone else experiencing this?

Hi everyone,

Just a few points of clarification:

  • This update is a PREVIEW of the upcoming 4.4.1 hotfix
  • To opt into this preview, you must add the parameter specified to your Launcher shortcut target
  • We are aware of an issue that occurred where the Launcher said “Update” for 4.4.0 which did not actually perform an update. We apologize for this.

I have also reached out to our Oculus developers to look into the performance issues that some of you are describing.

Thanks

My positional tracking seems okay. The main problem is that it doesn’t start where it did with the DK1 for me. It always places the camera forward and to the right of where the old positioning was.

What specifically is your positional doing?

Hi, and thanks for the info Stephan!
Only question I have is whether I should roll back the update or not? The update broke my plugin compatibility (Rama’s victory plugin, and substance plugin), they are telling me to recompile them, so I will most likely need to do this in the meantime.
How can I roll-back the update? I have a backup folder in the launcher’s directory from today, but it only contains a single .ini file…

Thank you in advance for your assistance! :slight_smile:

Thanks for the hot fix, Epic!

Hey guys, thanks for the feedback!

Let me try to address the issues in the thread individually:

  1. The positional tracking issues were a bug with the blueprint node for Get Position and Orientation, which we’ve just integrated a fix for, so it should make it into the final hotfix.
  2. We contacted Oculus, and they’re aware of the performance drop in Direct Mode. They say it should be fixed in the next iteration of the SDK. In the meantime, you can get a fraction of the performance back by doing “hmd mirror off” in the console, which will freeze the mirroring.
  3. Also from Oculus, make sure your DK2 has the latest firmware (2.11). They say they got reports of judder in multi-monitor configs in Direct Mode, and they’re working on fixing it. Extended mode shouldn’t be affected!

Awesome, can’t wait!

Awesome, just ran into this bug, glad to know it’s fixed. Thanks for the update!

So I just noticed that timewarp is now off by default? Did it cause too much trouble?

You can check by entering “hmd timewarp” into console.

Will it be available for github? Because I use github compiled version for multiple plugins.

Edit: Is this the one I find in github called Unreal Engine 4.4.1 Preview in pre-release section? Because it sayas "This release is still in development. " Is it the same as the one you mentionned here with launcher options or the github one is still not complete?

I’m using the 4.41 preview from Github and it seems to be working.

So the one in github is the same the promised update here? Please any Epic dev confirming that? Thanks !

I think it’s exactly what we have here, which is “4.4.1 Hotfix Preview”, just uncompiled. it says exactly that on Github, “Unreal Engine 4.4.1 Preview”.

I guess a preview of a hotfix is a bit confusing to people? :slight_smile:

I followed these instructions, but it doesn’t initiate any download. It’s still at 4.4.0. Any ideas?

Thanks.

Bryant

If you don’t get the option to UPDATE 4.4.0 and it does not say 4.4.1 right now then chances are you did it wrong. Refer to the code below to see if yours is correct? Also note you need to do this to the launcher not to the editor.

This is what my Shortcut for my Launcher says on my desktop. Note This is where I have my Unreal Engine installed and the first part will be different for you. Also note it is after the command to the UnrealEngineLauncher.exe which is in “” due to it having a space so pay attention to where you add in the extra commands on your shortcut.


"G:\Unreal Engine\Launcher\Engine\Binaries\Win64\UnrealEngineLauncher.exe" -AppLabel=Production-4.4.1HotfixPreview