Download

4.3 - Where's all the stuff?

So the preview release is out, and I’d like to know 2 things.

First, where is the world browser? I created my map with it in 4.2 and now I can’t find it anymore, all there is is this new Tile Map Editor which seems to have 0 functionality. I can’t find anyway to load my tiled world back up.
Second, I can’t find the integrated speed tree. I thought 4.3 was suppose to have speed tree included.

Is there some key-combo I must do to unlock the new features :P?

It’s been out for less than a day; It’s possible that it’s still being worked on and this preview is the foundation of 4.3 and not the completed build.

Yes ↑↑↓↓←→←→BA

Then wait.

Well I find it odd that the world browser is completely missing, its nowhere in the menu, and no longer under experimental…

I wish I could “like” forum posts hee hee

+1 from me hee hee

Rama

It’s because preview builds ‘contains features that may be in an incomplete state.’ :o

Edit : Hehe <3 Rama, Me too so i could like/+1 all your threads!

I want to say that it’s been merged into the level browser, but don’t quote me on that :slight_smile:

I remember that one… Contra!

Here’s a copy-paste from an internal mail about it from Dmitriy Dyomin. It will be in the next engine news post as well (so I’m not going to upload the images, they’re just pictures of the levels and level details tabs):

Cheers,
Michael Noland

Hi,
World browser is enabled by default with 4.3. It does not require special “Open World” command anymore. Instead there is a flag in World Settings “Enable World Composition” that activates it. New Levels Browser can work with both: “traditional” level streaming and tiled worlds. When “Enable World Composition” is enabled you should see an additional button in Levels Browser toolbar that summons world minimap. There is also documentation for World Browser, I hope it will make into 4.3.

Wow, 4.3 preview already. You guys are fast!

Ah thanks, nice.

We’re working on the 4.3 ‘preview’ release notes. Hopefully we’ll have the info about the new features and changes in your hands tomorrow! Of course, we will have exhaustive release notes when the build has finished testing.

Thanks Mike, really appreciate the hard work you guys are putting in.

Anyone else having problems building 4.3 (switching over from 4.2)? Seems like the Speedtree implementation is the culprit:

I applied the new .zip dependency content. I recreated the project files using GenerateProjectFiles.bat. Settings set to Development Editor and Win 64.
I have used Rebuild All. Three times (with normal builds inbetween).
SpeedTreeCore_Windows_v7.0_VC12_MTDLL64_Static.lib is present.

edit: Right-clicking the speedtree libs and I see they were blocked because they ‘came from a different computer’. I unblocked them. Tried re-building but still no success (‘can’t open inpput file’). Looking up error: http://support.microsoft.com/kb/815645

yes exactly the same here

edit.
rebuilt again, 1 succeeded, the editor opens and works but complains about speedtree missing

I’m also having an issue with 4.3, particularly the AIController. It looks like you have to remove the “GameFramework/” from “AIController.h” but now when it compiles it looks like it cant find the “AIController.h” file. Any ideas ?

Ok never mind, just figured it out. Have to include the “AIModule” now as one of the PublicDependencyModuleNames.

Is 4.3 release still going to have built-in support (or whatever) for Allegorithmic Substances?

This was mentioned in one of the last 2 livestreams. I want to say it isn’t fully complete but parts will be in 4.3? You may want to just watch the livestreams.