4.27 Water buoyancy not working?

Created a waterbody. Created a BP for my object and added buoyancy there. Created 4 pontoons. Object just sinks.

Tried using example object BP_BuoyancyExample and it sinks too. What could I do wrong?

1 Like

Could be a number of things. Make sure your object is placed way above the water surface. Radi of pontoons shouldn’t be too small. Maybe adjust dampening in the buoyancy settings and verify your object isn’t too heavy.

1 Like

I’ve found out that FOR SOME REASON Auto Activate checkbox was not checked in both my object and example


Hi, have the same problem. Could you tell me how to activate this? New in unreal

1 Like

Thanks for that! Works now! Was totally confused…

@anonymous_user_463fa72d You have to select the Buoyancy component in the Actor and under Activation make sure the checkbox Auto Activate is checked.


Working fine, thank you guys!

I have a similar problem but in my case auto activate in buoyancy component did not work . I tried to modify buoyancy coeff. increasing it to without any effect. btw the object mass i set to 8 (kg?). Pontons radi set to 10 (but using 100 also does not work).

The only major difference between my code and many example I see is that I’m using a pawn and not an actor … but this should not be a problem.

I tried also to use WaterTestMap in Water Plugin content folder using BP_BuoyancyExample but it just sinks.

I tried on 4.26.2 using Water plugin contents and it seems to works but if I create a simple cube with buoyancy (in the same level) it sinks all the times… the only way to make it work is to use EditorCube as static mesh.

I cannot understand where’s the fault but it sounds like a big-beautiful-bug…

Good work

It looks like from another thread that you can only have a maximum of two pontoons on the simple cube. I’ve found the same thing in my experimentation.

To test this, I used the OnWaterEnteredDelegate function of the Buoyancy component to check what force was being applied to the pontoon when it entered the water. If you split the output pin of that delegate function, you’ll see the vector for the force - then just print that out.

When I had more than two pontoons on the simple cube, I would have 0, 0, 0 as the force. But with two, it would show a force on the pontoons.

1 Like

This works for me! (The option is available on Buoyancy Component inside of blueprint)

You save me a huge headache! Thanks!

1 Like

I have another issue about this, and finally works.
If someone tried to solve this problem but nothing works, try this one:
WaterBodyOcean → Increase ‘Collision Extents’ value large enough.

Hope this could works for you guys!


Thank you so much!

1 Like

:heart::heart::heart::heart: Thank you so much !!! :heart::heart::heart::heart:

I’m having the same issue but none of the above is even being noticed by UE. It just sinks through the water like there’s no buoyancy there. In fact, without buoyancy I get the same result. In fact in fact, none of the settings under buoyancy do anything whatsoever for me. So the buoyancy component is being 100% ignored by UE. I’ve tried it on different meshes, a few different pontoon techniques, fiddled with the ocean and as I say tried all the above here. Nada, just falls right through and acts like the component isn’t even there which is definitely is. It’s getting real old seeing tutorials where it works first time for people since I’m also on a deadline. I won’t even try this on freaky 5 since the most basic things such as water test maps don’t work for me in that sorry thing, so this is on 4.27.

Any help epically appreciated.

1 Like

Thank’s, I had the same problem.Works fine now.