4.27 does not work steam sessions

UE4 Unreal Engine 4 Steam sessions plugin does not work 4.27 - YouTube why it does not work ?

They added some new subsystem variables for EOS changes and never set defaults for the Steam subsystem, so it doesn’t actually search for lobbies in BP only projects now (trying to go down the dedicated server query instead).

bSearchForLobbies has to be true to find them, and its false by default and the engines default nodes don’t expose it.

Ok I see… I will check that out do I need advanced session search node ? you know that one I don’t know the exact name… Where do you toggle that true false on off?

Ok so, I downgraded 4.26 using unconventional ways, " I had a backup" and it works now steam sessions and multiplayer and all… after 24 h of testing and testing with 4.27 nothing worked, so I recommend people to use 4.26.
Why is the new stuff so broken : /?

1 Like


Just arriving here after a few hours of frustrating sdk testing and googling.

Is bSearchForLobbies reachable in c++ ?
Is there a way to set it to true without recompiling the engine ?

I’m using 4.27.2, and it doesn’t seem to work.
Nobody is using steam in 4.27 at epic ?


For anyone bumping into this problem.
The variable is bUseLobbiesIfAvailable and the solution is here:

1 Like

I hope this finds you guys well and helps with the issues your having

I finally fixed this one see this project is 4.27. and using sesssions. Liberation Special Forces on Steam