Download

4.26Ray tracing shadows disappear in the distance

hello
I have a problem,In 4.25, ray tracing shadows won’t disappear in the distance, but in 4.26, this problem occurs. How can I set it
thank

I don’t know if this is similar, but you can check out this thread: RTX GI Shadows Disappear With Camera Distance - Rendering - Unreal Engine Forums

You can either increase your screen resolution. Or turn of the indirect denoiser.

Look at the picture.Used DirectLight RTShadow.But the shadow disappeared in the distance

Thanks,But it may not solve my problem

I try to use r.Shadow.DistanceScale=2,It works, but it doesn’t solve the problem completely.In 4.25, raytraced shadows have no culling distance, and I want to know what happened in 4.26

Can you show me at what distance it goes away so I can test it?

Thanks again.We only need to create two new Raytracing projects, use some simple geometry to build the scene, and use direct lighting to get the test environment. The RTshadow gradually disappears with the increase of camera distance

I don’t notice it happening

If you finished the test on 4.26, I think I should use another computer to test again,thank~

You should try… This was 4.26 NVIDIA RTX branch that I compiled from Github. But as I remember it behaved the same on mainline Unreal as well.

I’m having the exact same issue (Normal 4.26.1 downloaded from the Epic Launcher).
Setting r.Shadow.DistanceScale to 2 does make it slightly better but it still doesn’t go far enough, and setting it any higher doesn’t seem to make any difference so I guess there’s a limit to 2.
I thought the idea of RayTraced shadows is that they can go as far as possible…

Also I feel like in 4.26 the shadows are way noisier than they were in 4.25, I think Epic might’ve nerfed RTX