4.26 Water Bodies aren't working?

UE 4.26 released today and was ready to start working with the new water bodies. However, with the plugin enabled and dragging the water bodies into my scene nothing is showing up. Is anyone else having this problem or know what’s happening?

Edit: Ok, after forgetting about this thread the solution was to make sure your landscape has “enable edit layers” selected. If you drag out a water body and it doesn’t work, make sure a WaterBrushManager is in the scene. If for some reason it still doesn’t work, delete all WaterBrushManagers (you shouldn’t have more than one) and add a new water actor in again. This should make it work 99% of the time.

My lakes always appear under the terrain. I can’t move them up. They are always on the grid mesh.

where is that setting at? thx

Since its landscape dependent, make sure you tick the “enable edit layer” in your landscape properties.

I have the same problem. I followed all the steps, enabled the layer thing on the landscape and still nothing… I can see the trajectories but no water and the landscape is not affected by them.

yep, I did that. Still no go.

You could try verifying 4.26 and try again. It also took me a couple of projects before it began working properly, IDK why.

Interesting, this actually helped… Thanks!

For me it works when I run the game even PIE, but not at editing time.

  1. Delete your water bodies
  2. Add your landscape if not present
  3. Activate edit layers on landscape
  4. Add water bodies

Have you tried centering the landscape like to 0,0,0. the landscape and ocean have to be close to center. I am having issues with fluidsim, foam. Everything else works for me.

Me pasa lo mismo

I also experience this issue. Its experimental plugin. we must wait until it’s more stable in the next release of Unreal 4.26.xx

I did get this working. I enabled the plugin before importing the terrain. Once I did that, it worked fine.

I had the same situation! The problem in my case was, that there was no water brush manager in the level. In your “Place Actors” Tab just search “water”, select the water manager and drag it into your scene!

Bump, this solved the issue for me!

Still broken

The problem occurs when there is not any “WaterBrushManager” blue print in your landscape editlayers
to solve this problem first be sure that you tick on “Enable Edit Layer” in your landscape setting
then in Sculpt tab click on “Blueprint” then in tool setting chose “WaterBrushManager” in BlueprintBrush dropdown menu and then click in your scene
it will add a “WaterBrushManager” into your layer. now you can work with Water Bodies without any problem


That worked for me as well cheers!

Hey guys. I was also having an issue with water not rendering on an existing landscape. Moving the landscape to the 0,0,0 location works but I found another way. When I put down a water body in my level, there is a “Water Mesh Actor” that shows up in the Outliner. For me, this actor was at the point 0,0,0 and the culprit (looks like it’s the actor that displays the water). Moving the landscape to this point works but so does the reverse. You can instead just move that actor to the same location your water body is at and it should achieve the same thing.