Download

4.26 Volumetric Clouds don't appear when level is played or in rendered out sequence movie.

Hey. I am currently working on a project right now and I have spent a long time making an environment/level along with a finished camera sequence with characters etc etc.

Point is, I have used the new features ‘SkyAtmosphere’ & ‘Volumetric Clouds’ options for the environment. As they are clearly a better option, I used them. My issue is with the clouds and overall lighting of the level. When the level is played either in viewport or in standalone mode, the clouds do not show where they should be. The sky is just empty and looks nothing like it does in the editor. Also, the lighting is too dark when the level is played. I just want it to look the same as it does in the editor and its not behaving. I have tried adjusting and setting 1.0 1.0 on the exposure settings but that didnt help.

So when my sequence is rendered out as a video it is way too dark and the clouds do not show, exactly like how it does when I play the level. It is really starting to get on my nerves because I need it to be rendered correctly and I still haven’t been able to get it looking the same as how it does in the editor. I want it to look like how it does in the editor, and its just not.

Would appreciate any help, although ive done a lot of research and had no luck.

Hi @Captain_SG17 ,

I think I know what is going on:

  • for clouds, you need to set r.VolumetricRenderTarget 0
  • for the lighting: maybe you are using the new real time sky light capture? Then you should set r.SkyLight.RealTimeReflectionCapture.TimeSlice 0

Sorry that this has felt through the cracks of our 4.26 testing. In 4.27, we automatically disable those options when rendering cinematics (it also results in improved consistency and quality).

Hopefully that will solves your problems mentioned here.