Download

4.26.1 - Viewing volumetric cloud from above - shader issue

Hi,

This may be something really simple but I’m struggling to figure it out and can find nothing on Google/Forums, so any help would be much appreciated.

I have a basic level with volumetric clouds, a height map terrain and an ocean plane. From ground level everything works fine. However when I view the level from above cloud level, there is a ghosting effect around all meshes displayed above the clouds. I’ve narrowed this down to the material instance’s shader being used on the ocean plane. If I use “DefaultLit” on the plane’s MI there is no issue. However, if I use “SingleLayerWater” it causes the artifact effect when I move the camera, see below pic:

Does anyone know the root cause of this and could someone possibly offer some advise on what options I might try to resolve please?

Thanks in advance.

The visual effect it creates is called an aftereffect.

The reason why it’s doing it could be almost anything.

it would seem to be caused by the reflection that single layer water casts, or the fact it is a transparent/masked material perhaps.

How complex is your single layer water material? So we can try and replicate.

Thanks for the very prompt response!

I should have mentioned but, you are correct, it is related purely to translucent and masked materials. My terrain does not cause this effect at all. The material is from a market place add on Waterline Pro, specifically the 5_FFT_Ocean_Sim plane, but I can replicate using the OOTB plane and water material as well (see below pic. N.B. You will need to enable the new 4.26 Water plugin to get the below folder). I’ve tried both translucent and masked materials and they both have the same issue.

Other notes, I am using the Ultra Dynamic Sky pack for my clouds, although I have also replicated this using the OOTB volumetric clouds. If you do test with UDS you will also need to amend the volumetric cloud rendering parameter. It defaults to “Background Only Clouds”, so when you fly above the clouds the engine renders them beneath the ocean plane. I’ve amended the setting to “Clouds render above opaque objects (Quality)”.

Within the Water material it is also important to ensure these two parameters are checked:
Water Material.JPG

Thanks for looking into this, it’s very much appreciated and if you need any more info please let me know.

I have a similar problem, as soon as I move the camera to be as high as to enter the volume of my clouds I get a very heavy ghost for a few frames. the ghost gets ‘masked’ around my terrain too.
I’m also using SingleLayerWater for my water (so “apply cloud fogging” and “compute for per pixel” are greyed out). but also if I hide the water and keep only the atmosphere the issue is there as well

Hi Chosker, if it helps, I found fog also causes ghosting, you could try playing with your fog settings and disable it to see if that is the issue. If you are using Ultra Dynamic Sky he has also added a fog inside cloud parameter which you can disable.