4.25 New "Movie Render Queue" Skips Frames

The new Movie Render Queue creates high quality output with some fantastic anti-aliasing and motion blur options. However, it also seems to skip frames every single time.

I’ve tried different frame rates, resolutions, number of spatial and temporal samples, but it’s a consistent problem.

I just did a 250 frame test and it dropped frame 243 and 234.

This makes a great feature essentially unusable. Does anyone have a solution?

Yes, this the same for me. Every time I do a render of my 400 frame sequence it misses 181 and 182.
Or several times it will crash Unreal Editor all together with me submitting a crash report.

If I renumber the sequence and look at the playback in After Effects or Nuke there isn’t any stuttering or juddering as if the missing frames were needed.

I’m using Alembic caches out of Maya, set to skeletal Meshes on import. At first I thought it was a miss match of FPS 24 or 25 between Maya and the sequencer but I double/triple checked when it last missed frames and everything is set a 25.

Oh that’s really interesting. So maybe there aren’t any actual missing frames, it’s just incorrectly numbered?

Well don’t take it as the answer…it’s possible my animation is moving slow enough that it’s not noticeable.
I have been doing a lot of rendering this week with the same issue…only real solution is to adjust the time line sequence for about 10 frames including the missing one (s) and re-render.
It’s a pain but it works. But I can confirm the error (missing frames) happens every time and I’ve tried both exr and png with alpha when I have a sequence over 180 frames.

For now the only other solution that is working is to setup renders in batches of 100 and use the "custom start / “custom end” frames offset in the Output of the sequence…bit of a pain to keep changing it but it works

do you guys have Time Dilation in your sequencer?

I tested to create a sequencer with 10 in Time Dilation the image name will be 0010,0020,0030…

So it seems the frame number is the sequencer frame not the time that after speed up

And I try to set the Time Dilation to 0.1, the image may have same names and been overwrited

10 Frames in sequencer with Time Dilation to 0.1 should have 100 images , but this are only 10 pictures

use {frame_number_rel} in render setting should be ok

Was also having this issue and this is the only post I’ve seen addressing it. Was using time dilation in sequencer and getting weird frame skipping.

{frame_number_rel} works!!

Epic, this should really be a checkbox in ‘Output’ - please implement.

Thanks so much for this!

Where exactly do I need to put {frame_number_rel} in my Movie render Queue window? I have tried a couple of spots…
I can see it in the movie capture, but would like to know how to use it in the hi-res render queue…
Any help is welcome :slight_smile:

I thought this code may be put in render setting-frame name,but when I render whole timeline(all 960 frames),it still skip some frames…

350190-微信截图-20211013181300.png

I have the same problem, and this trick doesn’t fix it.
I have a sequence of 120 frames, I put it inside of another sequence as a “ShotTrack” and I want to apply a time scale of 0.8 on it. it works perfectly in the editor, but when I render in the movie render queue, it still renders 120 frames and it skips some frames. normally, 120 frames playing at a rate of 0.8 should render 150 frames. But it doesn’t.
Hope it’s possible to fix. or we’ll have to wait until 4.28 ><

If you used a template that already had cameras and a sequencer set up, it could be that the camera master sequencer has information to look for a new camera. You can delete the main sequencer if you are just wanting the one shot and it should then render fine.