Download

[4.25] How to Fix Animation Compression Crashes [SOLVED]

If you disable the Event Driven Loading, the debug log will include the path to the animation. Somehow many animations have problems with loading properly, and this subsequently results in a crash. Can this new compression feature be muted somehow?

If you do not disable EDL, you get an Exception Access Violation error. Exporting/importing affected animations may fix the issue, but cumbersome task, since it may involve many files, and you have to build the project each time to find out which animation may be impacted.


[2020.05.09-11.31.12:438]  0]LogWindows: Error: Assertion failed: !Obj->HasAnyFlags(RF_NeedLoad) [File:D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Engine/Private/Animation/AnimCompressionTypes.cpp] [Line: 403]
[2020.05.09-11.31.12:438]  0]LogWindows: Error: Failed to load AnimBoneCompressionSettings /Engine/Animation/DefaultAnimBoneCompressionSettings.DefaultAnimBoneCompressionSettings in AnimSequence /Game/Assets/Props/Vehicles/Ships/Schooner_Hannah/meshes/prefabricated_element/skeletal_meshes/sail_5_Anim.sail_5_Anim


https://github.com/EpicGames/UnrealE…ssionTypes.cpp

Cross post https://answers.unrealengine.com/que…n-crashes.html
‘Failed to load AnimBoneCompressionSettings’

UPDATE/SOLVED
Read the latest posts.

I also have problems with the Animation Compression :

When UE 4.25 makes an Auto Save while the animations are compressing it takes forever , especially when the animations are very long.

Is there a way to deactivate the new Animation Compressor ? I deactivate Auto Save for now.

Same issue here when i package my game. It starts up and crashes immediately with this error. Any solutions found besides disabling EDL?

Also have this issue 4.25

Even worse for me, I can’t even get my project to Open with UE4 4.25 because it accuses my animations of having “no scale keys”.

LogAnimationCompression: Warning: When compressing Human_EvasionFront01 track 24: no Scale keys

It then crashes with the following error:

Assertion failed: Q.IsNormalized() [File:D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Engine/Private/Animation/AnimCompress_PerTrackCompression.cpp] [Line: 340]

Super frustrating.

Posted a quick update for 4.25.1 here https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1755531-unreal-engine-4-25-released?p=1774012#post1774012 It is not entirely clear what project settings may cause this error. I assume it is AsyncLoading enabled, Level Streaming enabled… perhaps another setting.

Do you know if its possible to disable these settings without opening the Editor?

Since it crashes before I even open it, I can’t change those settings in the editor.

You can look at the config files, edit them with Notepad.

I worked it out guys, so with theAssertion failed: Q.IsNormalized()

There is most likely an animation that is causing the crash, the best way to fix this is by validating all ur folders and if you get a crash with Assertion failed: Q.IsNormalized(), then you know there is an animation in that file that is causing the issue, try and open up each animation until it crashes, once you find the animation thats casuing the issue delete it, you may have to delete it from the file because if you just single click on it that seems to make the engine crash, repeat these steps until you can load your game up.

If you cant even get into your games engine then you have a bit more of an issue, you will have to go through the game files and copy the anaimtions put them into a new folder on your desktop for example, and then delete the animations from the project i would suggest deleted 10 animations at a time once you find whats causing the issue delete that anaimtion and then paste the ones you deleted back into the project, hopefully the game should load without a crash.

We also narrowed down the issues with EDL.

So to fix the issue, we :

  1. activated EDL
  2. cleared the Intermediate folder and the Saved Folder
  3. re-cooked everything

To come to that conclusion I initially cleared all the config files and deleted the cooked assets. That fixed the issue.
I then reintroduced all the settings in the config file with the exception of EDL.

Edit : Some of the animation assets didn’t have any Compression Settings assigned, which caused a similar issue. But at that point it’s just a matter of assigning the Compression Settings.

Not working…

Turn on EDL actually remove this error message, however, it triggers another error message:

Assertion failed: AsyncLoadingThread.RecursionNotAllowed.Increment() == 1 [File:D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/CoreUObject/Private/Serialization/AsyncLoading.cpp] [Line: 3959]

Based of suggestions from this thread Event Driven Loading broken / Async Loading Thread broken - UE4 AnswerHub

I should turn off EDL…

There is still no solution for me…

Also still trying to get to the bottom of this tedious error. So far it appears that animations are not the culprit, since replacing them with fresh original market packs, is not fixing the error, as well as related compression settings.

Perhaps it has to do with some sort of flag settings, or loading of animations from another level.

Tracked the error further, now getting this error


LowLevelFatalError [File:Unknown] [Line: 3899] AnimSequence /Game/Run/Animations/CC3/Locomotion/Sitting/Sit_A_ground_kneel_02_loop.Sit_A_ground_kneel_02_loop: Serial size mismatch: Got 37256, Expected 37280

Affecting what seems all AnimGraphs animations.

Deleting derived data cache, recreating the project,deleting temp folders, switching affected animations with originals, won’t address the issue.

Okay, so finally I was able to successfully debug the issue, this is what I did:

Keep project settings, basically ignore errors, since they do not point to the actual culprit.

  1. Run the editor Launch option with for instance a minimal project configuration, i.e. a single map migrated to a fresh project, including copy over config files, plugins.
  2. Remove from the minimal new project for debugging purpose, folders until the project is no longer able to Launch. If you still can Launch, re-add the previously removed project root folder. Launch is a sort of in-project compile/deploy option.
  3. Once the Launch starts to fail their is a high chance the current removed folder contains the project corruption.
  4. Now re-add the suspicious folder, and start removing sub-folders, until you can isolate the project threat.

In my case, this method yielded a root AI BP and a Enumaration BP. The actual error is related to a certain child AI BP in my project, and removing some blueprints resulted in successful Launch deployment, and because the issue was found, subsequent successful packaging. Because Launch works even with errors in the log, packaging requires to fix those first.

It is still unclear why exactly the AI child BP started corrupting after upgrading from 4.23 to 4.24 or .4.25, perhaps I can shine some more light on this later.

Is this still related to the animCompression crash? I tried removing every animation except for 1 in my project and the animCompression crash is still occurring. Are you saying it’s a corrupt BP that’s causing this and not the animCompressor?

It is possibly related to Animation Compression, but not directly connected to animations, instead likely related to AnimBP’s using such animation. In my scenario removal of a certain, single, AnimBP - part of an old Mixamo Fuse setup, resolved it. I checked the AnimBP but couldn’t find anything out of the ordinary. So this remains a very stealthy issue.

After working awhile with content, today when testing the build the Animation Compression error came back! But this was not really very convenient, packaging for shipment, no errors, and upon launch just freeze without any error in the log. Removing levels, and repeatedly using the launching feature from PIE, and with Event Driven Loader disabled the error surfaced then. First I thought this must be another corruption not previously discovered (also had a corrupt system SSD), but all seemed fine. Then I tried to launch with the previous working Engine.ini, and voila it works again. I know, super strange, right?

I did not yet brute forced what setting change exactly, but here is the working one

And here the faulty

So if someone else comes across this issue, check the working Engine.ini, perhaps it helps you too? *Collision profiles omitted.

Nothing helps at all. The project is under threat, help!

Hi, im sorry for reviving this post, i have tried everything that you recomended before with no luck. this issue for me is only happening when i comile the server, it is not happening to me directly in the engine or during any of the paly actions, not even running it as a standalone. I have tried building directly from UE4 and also through the frontend, nothing helps. if anyone has some light to bring here please let me know, i have a 6 years old project stopped because of this issue.

P.D: Im having this issue on 4.26.1

This bug has me stuck with UE4 4.23 since forever

I’m extremely disappointed.