[4.25] How to Fix Animation Compression Crashes [SOLVED]

Im bumping this since i really need to resolve this and i am out of ideas…

We have to hope for a dev to step in and help us

Guys as I have explained, this issue is very likely due to corrupted files, in my case the culprit was a faulty ssd. To resolve this start removing folders ( and or default configs) and use the launch in editor feature to get notices of potential files causing the issue. Good luck!

Not sure how this is solved or explained. Or how your faulty SSD is related to this issue. At your “working” config, you have EDL disabled, at the “faulty” config you have EDL enabled.


So all it seems to come down to is to disable EDL, as that’s whats causing issue with else completely fine Animations. What is interesting though, is that you use Mixamo Animations, which are used in the Project where I got the Error as well. If other people who are having that issue are using Mixamo Animations, it would be a hint that EDL has some issue with those Animations for whatever reason.

All in all this seems like a Engine Bug, I don’t know where you take the confidence from, that it’s related to corrupted files.

  1. Consider animation errors a smoke screen, you can remove them but the error will randomly report others.
  2. Also not related to a specific animator source.
  3. Event Driven Loader was disabled since it offers a few more pointers in regards to debugging / errors.
  4. Using a default config may help to pinpoint the error source.
  5. When a new engine version is released, usually most files get updated, in the process errors may surface, which however were dormant for longer periods already.
  6. Removing project folders is another method to narrow down the source of the problem. Usually meshes or textures, none code involved assets may be corrupted, blueprint code on the other hand may suggest a code issue.
  7. The launch feature is another important method to debug in real-time, when observing the output log.

Thus, use mentioned methods and eventually clean config files to find the bugs.

So what was the issue in your case then? How did you fix it? Above you mostly mention how you tried to track it down, but failed and seemed to be irrelevant except your config file - where the only relevant difference seem to be having EDL disabled, which brings us back to the start.

working engine ini = EDL Disabled.

Can say exactly: 1) Unit23 introduced everyone in delusion and marked the topic as SLOVED, and it is bad. His problem is not related to ours. The Harddisk is definitely not to blame.
2) New Animation Compressor crash with Mixamo Animations
3) Why are so few people with this problem? No one uses Mixamo animation in their projects other than us?


I have this issue too and I haven’t been able to fix it. I’m still using UE 4.23 because of this exact issue.

Tell me how to contact EPIC. The problem exists and we need to ask them about help.

1 Like

any update on this?

1 Like

The issue is a bug that they fixed for Shipping builds, but some oversite made them forget to fix the bug in Dev builds. We had this happen in a Point and Click game where we were using Widgets as Cursors. The entire issue with what you think are broken assets is a false positive, a red-herring. The real fix in our case was to move the Cursor Widget the folder Contend/Slate. Slate is the subengine that draws widgets and we were using Widgets as Cursors.

1 Like

Just make a Fix Up Redirectors in folder for the Content folder

I’ve managed to fix it. The root problem of this error is the bone compression settings are not being loaded properly. From my understanding, they are loaded when this function is called.


And that event is only called when EDL is enabled, so if you have it disabled, you must enable it and fix any errors EDL may give you. For me, EDL caused issues if I called
in the constructor of a class. So my solution was to either remove all
calls or move them from the Constructor to BeginPlay or Init functions.


You saved my project!! Thank you!!!


@Thezigner Can you explain how you ended up fixing your issue?

Never mind, I was able to figure it out.

For anyone else wondering how to fix this issue, follow these steps:

  1. In your <PROJECT>/Config/ folder, edit the DefaultEngine.ini file and include the following piece of text under the [/Script/Engine.StreamingSettings] header: s.EventDrivenLoaderEnabled=True

  2. Rebuild the environment, and this time, the build should fail, yet point to a different error: PackagingResults: Error: EDL dep graph contained a cycle (see errors, above). This is fatal at runtime so it is fatal at cook time.

  3. Review the log (or find in C:\Users\<USER>\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_<VERSION>), and just above the line that reads UATHelper: Packaging (Windows (64-bit)): LogWindows: Error: === Critical error: ===, it should point to the trouble object.

  4. For lack of a better solution, I deleted the object from my environment, and I was able to rebuild and launch my game.




There is no [/Script/Engine.StreamingSettings] in the ue5 version can help me through?
Also I can’t enable EDL I searched it on the internet but there is nothing about it.