Download

4.24 Vive controller not showing up after packaging.

I have a Vive specific VR project migrated from 4.20. Everything worked fine in 4.20. But now, when I package with 4.24 and launch, Vive controllers don’t show up. Headset works fine and all other functions work fine. Just no controllers so can’t teleport. The file was based off default VR motion controller template.

Controller does show up and function as expected when launched from editor via VR Preview in 4.24. Problem only happens when packaged.

Just to see if migrating was issue, I created brand new VR project from the default template in 4.24. Then packaged it. Same problem. Controller shows up when launched in editor but doesn’t show up when packaged. If someone can test this with default VR template and let me know if the controllers show up after packaging, it’d be appreciated.

I’m guessing it’s probably something that changed between 4.20 and 4.24… I’m seeing something different in interface too. I see SteamVR Input button in the editor (attached image) which I’m not sure what it’s for. Any help would be appreciated.

I’m using Vive Pro.

Thanks, I put the folder in the directory it’s looking for and it says it’s successfully found the bindings. (Attached image from log) But it didn’t fix the issue. My controllers are still not showing up in packaged VR. Can you confirm this works with default VR motion controller template?