[4.24] Lightbuilds started from commandline not connecting with swarm coordinator?

So recently we added a seperate buildstage to our pipeline which just runs the build for lights through the command line. A thing we noticed, compared to running from editor manually, is, that it does not pickup a connection to the swarm coordinator, and therefore keeps running on the light task alone. All other light builders have their swarm instances connected to the coordinator and the coordinator runs on the same system our commandline is run on.

We use gitlab, and therefore gitlab runner (which runs under a useraccount). Swarm coordinator has been started by a user manually on the desktop, and is already running when the pipeline is kicked off.

This is how the commandline looks like:
“%CI_PROJECT_DIR%\OurProject.uproject” -run=resavepackages
-buildlighting -mapsonly -projectonly -allowcommandletrendering

anyone has an idea?

Hey @Memnarch,

I hope you had your answer after all this time but I had a similar situation and realized that I had to completely disable my firewall on the workers and the coordinator for Swarm to work by command line.

No we didn’t get it to work, so we went with just the mainserver building for the time being. However, your response seems interesting and we’ll try that one.