Download

4.24.2 - How do I set up Vive Tracker with the SteamVR Input stuff??

Setting up controls in Unreal used to be easy and fast, but this new system is completely unintuitive and confusing. Did they even test this with actual users?

So I’m in 4.24.2 and trying to add a Vive Tracker to my project, but it’s just not picking it up. It used to be a matter of adding a Motion Controller Component and setting the source to Special_1, but it’s not working now.

Am I missing something?

After almost 2 hours I figured it out.

Step 0. In your UE4 project, open the Project Settings, go to Description and fill in a Project Name, in my case “VirtualStudioProject”
Step 1. Pair the Tracker with SteamVR, and rightclick it and select Manage Vive Trackers
Step 2. Give the Tracker a Role, in my case I choose “Camera”, click Close
Step 3. Go into SteamVR settings, enable the Advanced Settings, and under Controllers find the button “Show Old Bindings UI”
Step 4. In the new window, select your Unreal project, with the name you gave in Step 0. In my case “VirtualStudioProject”
Step 5. Under “Current Controller”, click the “Vive Controller” button, and now you should see “Vive Tracker on Camera” (This only appears after you selected a role from step 2. There will also be a regular “Vive Tracker” option, this one does not work)
Step 6. Under “Current Binding” click Edit.
Step 7. Now click the button “Edit Action Poses”
Step 8. In the new window, click the button “Unused”
Step 9. And finally, now for the part I’ve been looking for for hours: Select “Special 1”

Now it should be working again in Unreal, if you add a Motion Controller Component, and set the source to Special 1.

As you can tell, this is not intuitive at all and a huge step back from what it was.

Thanks for this info! Not sure if you can help but for some reason I still can’t quite get it to work. Even though I have added a project description it still says “UE4Editor” when I try Step 4. Anyway, I’m guessing that should still work even with that. But when I get to Step 8, I click “Unused” and only get 3 options. “Left_pose”, “Right_pose” and “Unused”, no “Special_1” etc. Any ideas?

I am using 4.19 but it looks like Vive Trackers were supported in 4.17 so that should be ok I guess!

Cheers!

EDIT: Tried on 4.24 and it worked straight away. Will leave this here in case anyone else has the same issue. Thanks!

Sorry if I have a question.
is possible to associate multiple Vive trackers in a project? i have three vive tracker and i’d like link this to three different object in my scene.
In Steam Vr I can associate multiple live trackers but when I choose the device I can only see one live tracker.
There is a solution, im a beginer .

Yep, first add 3 motion controller components, then on each one you need to set the motion source ( in the detail panel ), set them to “Special1”, “Special2” and “Special3” respectively.
Attach a cube ( or whatever you want ) as a child of each motion controller, and as soon as you hit play you should be able to move the vive trackers in real life and see them moving in the viewport

Hi, [USER=“2200”]Enter Reality[/USER] !
I tried to use 2 controllers and 2 vive tracker. But, somehow, the system only able to recognize 2 devices.
But if I change the binding system of the vive tracker into the camera and set the steamVR vive tracker camera as Special_1.
I manage to show 2 controllers and 1 tracker. But I can’t manage to show the other one. Because the steam VR vive camera binding system can’t be set twice.
Do you mind show me some steps or tutorial on how to do it? Thank you

yes,i found this problem,can you solve it?

I found you need download steamvrinput plug

I have a same problem, no “Special_1”.
I upgraded tracker firmware, and already downloaded and installed steamvrinput plugin.
Even i updated bootloader following in the document, HTC-Vive-Tracker-2018-Developer-Guidelines_v1.5.pdf
https://dcnpy7o9bh2w4.cloudfront.net…lines_v1.5.pdf

Any who have idea to solve it ?!

Thanks for that, glad I came across this post!
Still running into an issue where as soon as I go in game, the Vive tracker gest very jittery and disconnects constantly though.

And I’ve run into another issue actually, not sure how this started but I noticed after I switched trackers because of batteries dying I had to update one. Then I couldnt get it work in UE suddenly when I hit Play. Now when i launch SteamVR, it keeps trying to show the goggles on the desktop with the trackers sort of moving in the background. But if I close the window, SteamVR says it has encountered an error and has to restart.

So lost the setup somehow! All settings the same! Any help?!