4.20 crashing days after release

Okay I’ve just installed 4.20 on my HP Pavilion Laptop Intel core i7-7700HQ Processor NVIDIA GeForce GTX 1050 GB, working away on a couple of Udemy projects and would you believe that it works fine one second, but YES you guess it, CRASHES the next! Now I know they at Epic Games are trying to fix the recent releases (for example: 4.19.2 - which crashed consistently) of the time of writing this, I’d thought, 4.20 would sought out that issue, however it seems on my laptop it’s anything but resolved! The issue of the constant crashing needs to be looked in - as a top priority, as of the last three updates, it’s been getting from bad to worse! It’s a good engine only if it works and is 100% reliable. As of today 07/22/2018 its nothing but a piece of software, waiting to release it’s full potential. Which it is still doing!!! Guess I’ll be waiting for 4.20.1 or 4.20.2 to be released!!! Brandon

Just to follow up on the last message for those at Epic Games/Unreal Engine Studio - I’ve tried one more time just to make sure it’s not me, the laptop of a bolt of lighting striking at the same place twice! I’ve got the “Crash reports comprise diagnostics files (click here to view directory) and the following summary information”


You do not have any debugging symbols required to display the callstack for this crash.

If you want to get more information about your crashes, you can download the debugging symbols (just know that this is around 19GB). You can do this from the Launcher’s Library page, clicking the dropdown arrow on the engine slot, and choosing Options > Editor symbols for debugging.

I’ve pulled up your Crash Reports and you’ve experienced a few different crashes lately. One was related to Blueprints (UE4Editor_Kismet!SMyBlueprint::OnActionSelectedHelper() smyblueprint.cpp:1579) and if you can determine a reproduction case for it, be sure to submit a bug report.

The others are GPU crashes. There’s a bit of variety, but they are all effectively this same GPU crash: Unreal Engine Issues and Bug Tracker (UE-51650)

At this time we do not have a definite cause or solution for this crash. You should make sure your graphics card drivers are up to date, and can try some of the recommended solutions to see if they help you.

I’ve supported the most recent crash to the submit a bug report link. I couldn’t see where you were referring to the Download the debugging symbols as there’s no option I could select in the Engine Version (Library) page; when I do select the prompt within the engine version it states

19.6 GiB (Total size of all installed engine version)!!! Confused much!!!

I’m going to wipe out the recent installed version and reinstall it on the laptop (I’ve updated my graphics cards to see if that was indeed the cause. It crashed a few minutes ago so I’m going to try that after re-booting my laptop, just to make sure!

Many thanks for your reply (it’s good to know someone is listening)! Have a wonderful day. Brandon

Nope even updating the graphics card on the pavilion laptop doesn’t solve the crashing - it uploads fine and everything, but moments in starting the development of a project it just freezes and then comes up with the Unreal Engine 4 Crash Reporter. I’m going to submit another bug report so that it can be resolved with another mini update!

But to get a heads up here’s the latest crash bug!



To install the debug symbols, navigate to the engine tab (where you normally install engine versions) - click the yellow down-arrow on the engine you have installed and select options. That will bring up a Dialog box allowing you to install the extra items.

I have some issues with UE4 on my system. First of all I’m using Asus ROG STRIX GL553VD with intel i7 7770HQ processor, 16gb DDR4 RAM, 1TB HDD/255gb SSD and Nvidia GTX 1050ti 4gb. The issue with the system is UE4 crashes very frequently, first i thought it’s the engine version but its more clear in the resent few days that regardless of what version of the engine i use, the editor crashes frequently. Anyone has idea about what could be the issue? i’m on latest windows 10 built and i keep all my drivers up to date so aside from that i really have no idea what causing this

:confused: i’m well aware that the engine doesn’t work well on laptops but is it the main reason why its crashing frequently? It crashes when I try to import models, or when I hit play, open a blueprint maybe or just randomly crashes. I’ve tried resetting my PC, fresh installing the epic game launcher but nothing seems to work, at this rate whenever i open up my project the editor instantly crashes, tired of this why nobody fixes it ughh!!

Your crashes are fundamentally the same as the ticket I linked to above for BFuller.

The Editor crashes because it takes too long for the GPU to respond.

Sometimes crashes like these are perfectly valid. If a GPU is slow or faulty, the editor crashes because it has to…since it cannot run without input from the GPU.

However we do know that we are seeing more of these crashes than we would expect to be normal, so there may very well be another issue at play. The cause of that is still under investigation.

Mr Stephen Ellis I mean no harm in my posts to the team at Epic Games who are trying there utmost to solve these issues; however it’s stressful when something is out there and its not entirely fixed as it would seem to be. Granted there will be issues from time to time, again I must say that if those errors occur how are they getting resolved from Epic Games end? The GPU has been updated as the laptop I speak of isn’t a year old! So it must be a GPU issue as others especially on social media sites have explained to me (today) that other GPUs are functioning fully thus resulting in no crashing of the editor what so ever! I don’t know what else to say really. It’s a good engine, but why stop there, when the good could be turned into the word “GREAT engine” You are right to point out other issues could be at play here, so it’s just a matter of playing the waiting game until it’s fully resolved! Thanks again for your remarks, to state that’s its being looked into! Best regards Brandon

I’ve been struggling with this issue since 4.19.2.
I’m using a Razer Blade 14: Intel i7-7700HQ 2.80GHz, 256 SSD, 16GB RAM, Nvidia GeForce GTX 1060
After reading multiple posts and finding no real answer to the problem, I’ve just tried using the “Verify” option for 4.20 in the Unreal Laucher. I’m 20 minutes in and have been opening and closing the material editor on and off (which used to crash my UE4, guaranteed).
For the Epic Games Staff and anyone experiencing the same issue, try using this method and let us know if it helps you too.
Best wishes, Mara

Have you had the issue of crashing from that update or was it just a one off event? As of today 07/31.2018 its still crashing Mara, as I’d hsave a long indepth chat with the team at NVidia themselves, changing the set up within the laptop, reinstalling everything, as well as discussing the issues at hand with a member of the community, its still crashing. At the time of this writing I’ve tried everything, but the kitchen sink, Changed the settings within the NVidia prompt, when right clicking the mouse on the desktop, but to no avail. I can even say that I’ve hard reset the entire laptop back to its factory settings 3 times over the past week, which hasn’t worked. Persistence and not resistance, is futile in this respect, even that is starting to wear a bit thin now 4.20.1 is a crash and burn situation. I don’t know what they are trying to achieve at Epic Games, but as of right now, a crashing engine, should be the top of there list to fix, before adding new features to the engine! Thanks for your advice Mara, I’ll keep plugging at it until something is sorted out! Regards Brandon

Hello, if it helps anyone I was having the same problem, and i diagnosed it to a slow response from the graphics card, to fix I forced the NVIDIA control panel to use the GTX 1060 as default ,Open NVIDIA Control Panel 3D Settings,run the editor and then hit add in the NVIDIA control panel and choose Unreal Engine then set it to always use the GTX card and Apply settings. Restart Unreal and off you go. The integrated 630 was running by default and the GTX was being started when needed but not quick enough for the editor, well thats what I decided from the debug logs.

Hope it helps someone with NVIDIA at least.

I’ll give that a try over the weekend. I’ve made the changes to verify Unreal as was mentioned by @MaraAnkiri so that seemed to work (from the offset of rebooting the laptop. I have made the changes you had suggested as I was explained when making those changes by NVidia themselves, but then it worked for a short period of time, but I spoke to soon as it froze again, then shortly after the freeze it closed down. I saw on a forum in Facebook, amongst the groups that some where having the same issue - works one sec, but then freezes and crashes the next! I was explained to go the other way because on that same laptop I could switch graphic processing units to try the Intel part to see if that stops the freezing, so I’ll try the editor this weekend to see if that and other suggestions resolve these issues! thanks for the advice. Best regards Brandon

I was having this problem as well, but seemed to have solved it in a really weird way. The laptop, that I use for 95% of my work, has a 540m and an Intel 3000HD. I have a shortcut to the editor and instead of launching it with the 540m, I launch it with the integrated card. UE will still make it force the 540m(confirmed within the logs and Nvidia GPU Activity), but it seems to alleviate my problems. In the logs, it will show that the Intel card is only DX10, so I presume that it’s forcing the Nvidia card because it has DX11.

I had been getting BSODs with the watchdog error just trying to open the project browser. I was also getting random crashes with the material editor. Haven’t had one since I started booting UE with the integrated card.

Again, this is a really strange workaround and I can’t exactly explain why it works, but it works and it’s definitely using the 540m…

Same crashes its a pain in the ass when im trying to build a game and i cant stream because of the crashing always going on

I’ve never had as many crashes in any other version than 4.20. Just today alone, I’ve had at least 8 crashes just at random. Usually straight after I hit compile on a blueprint and before clicking save. I’ve lost and had to redo so much work today.

I’ve tried everything but throwing the kitchen sink at it and it still freezes (as of update 4.20.2) I’ve checked all the drivers (NVIDIA, Intel, Windows operating system) and they are ALL up to date. However no matter what I try and do, it works well for one second, then literally unusable the next. I’m unable to change the setting in Intel because there’s not a option to link it to the Unreal Engine Editor. I’ve linked the NVIDIA graphics card to the Unreal Editor and it still freezes and crashes! It’s becoming exhausting to even want to install the update, because at the back of my mind I’m thinking “Is this one going to WORK?” Something needs to be done, because it was working FINE up until version 4.17, then it went downhill and fast!

MSI GS65, constant crashing in the editor. Simpy loading a mesh or trying to edit a material.

Unreal Engine is useless to me atm…

Edit: Did a couple of things, so far so good.

Verified 4.20.2
Also went into Nvidia settings and changed the Preferred GPU setting from “Auto” to “High Performance Nvidia Processor”

With update to 4.20.2 I can no longer open a new project, nor open a project made with the 4.20
When I open the editor, it comes to 72% closes and does not give me the crash report, just a windows screen that says it is sending a report to microsoft!
I use a MSI GT75VR 7RE Titan PC with a GTX 1070

Back to crashing 4-5 times until I can do something as simple as creating a new folder.

Simply cannot work like this, at this point I need to decide if I continue with the engine or move to Unity.