4.20.2 - Can't make APK without compiled .so - for all 4.20 projects

Just upgraded to 4.20.2. I noticed I’m getting a “Can’t make APK without compiled .so” error when building an android package for the GO. It happens now with all my 4.20 projects. Can anyone confirm if its a 4.20.2 bug or something else on my end? Any suggestions how to fix this?


  • tried de-installing 4.20.2 and reinstalling 4.20.2
  • tried re-installing AndroidWorks over the existing AndroidWorks
  • tested a 4.19 project - it still builds ok.

edit 2: I managed to get something working again;

  • go to C:\Program Files\Epic Games\UE_4.20\Engine\Binaries\Android
  • copy the .so and .target file
  • go to your project \Unr\Binaries\Android
  • paste these two files and rename them conform the error in the UE output log.
  • change in project settings the packaging settings to Development. Un-tick ForDistribution.

At least I can get a build going again. Launching to the GO from the top menu bar fails though again with an error - this time it can’t find the UE4Game-Android-Shipping-armv7-es2.apk file

edit 3:
Strange thing is - the behavior is not consistent, I have one 4.20 project that isn’t affected. Its in Shipping & ForDistribution mode and it turns out, the project already has the .so and .target file in the correct project folder. I have no clue whats going on here…

edit 4:
Too bad - the project from edit 3 is now also not building anymore; clang++.exe: error: linker command failed with exit code 1…

edit 5:

  • Deleted the NVPack directory altogether, rebooted and re-installed AndroidWorks form the UE directory - just the standard default setup.Seems to work again - crossing fingers…

I am having this exact same problem! I am getting one of the follow errors no matter what I do.

Having the same issue!

I saw today that Nvidia has updated Codeworks to 1R7, I am going to give this a tryi

Folks with this issue - have you reported the bug using official bug report form? Cuz you know, no one will care for this bug report when it’s done on the forums.

How does one know if this is a actual bug or not? Or if its just something to do with our machines? Also you think someone from Unreal that manages these forums would at least respond to this and let us know if this is a actual bug or not…at least I would hope the would.

Do you have Visual Studio installed?

I’ve been trying to find a solution for at least a week. maxbrown, others have said your work around works. My problem is, when I go to paste the files in my project there’s no ‘Binaries’ folder for me to open. Any idea how I can build that folder? I’ve installed the android works packages and have updated the support repository in the Android SDK Manager in the NVPACK folder. I’ve never seen a ‘Binaries’ folder since I’ve been trying to fix this problem…

@VHDT10 If those directories don’t exist, just create them using Windows explorer. You could also try my last solution (see original topic- edit 5) to just delete the Android folder from your system and re-install a fresh new version.

Gonna try deleting and reinstalling the NVPack, I’ll report back…

I also do not have those folders in my projects. I also tried deleting and reinstalling the NVPack and it didn’t work either. VHDT10 do you have Visual Studio installed?

Anyone else have any luck with maxbrowns suggetions?

@Three65 It still doesn’t work for you?! - too bad… Have you tried de-installing 4.20 and AndroidWorks, reboot and re-install 4.20 and AndroidWorks (just default settings) ?

No still doesn’t work, I haven’t tried uninstalling both I just uninstalled AndroidWorks and reinstalled like you said and still I get the same error. Makes me wonder if I need to have visual studio installed to make it work. Which doesn’t make sense, but who knows. I wish some other people would replay and say if your suggestion worked for them or not and if they have Visual Studio installed so I could try to narrow it down.

Deleted everything and reinstalled, I am still getting the same error. I think it’s time to go try unity and see how that works.

I’m not sure if this helps anyone, but I’m experiencing the same error as soon as I disable any plugins and try to launch the project (see my other thread here)

Hey All,

I have reproduced this issue and logged a report for it here Unreal Engine Issues and Bug Tracker (UE-63725) . You can track the report’s status as the issue is reviewed by our development staff.

Alex I am also having this issue when trying to launch to my Oculus Go, I haven’t disable any plugins at all. Will this also be fixed with the bug report you logged?

Hello, I can’t reproduce this on my Go without disabling plugins, however I’d imagine a fix for this would encompass all Android based devices.

Thanks for the update Alex. Any idea if there is a workaround for now? Or will we just have to wait for 4.21?