[4.2] Laptop Rotation Tracking not working


We have a project that runs fine on our workstations with the DK2 and UE4.2 - head rotation works fine, positional tracking isn’t required right now. However, when we run the demo on our presentation laptop, a MSI GT60, we lose rotation tracking. The video output to the Rift is fine, but without rotation tracking the demo falls flat.

Our DK1 on the same laptop tracks correctly, using the same demo that we’re running on the DK2. Previously, if the tracking didn’t work on the DK1, we were able to disconnect and reconnect the USB - which would restore the tracking. However doing so on the DK2 causes the application to CTD.

The tracking works perfectly in the OVR config utility demo scene on the laptop. Still no tracking in UE4 or Unity based applications/demos.

We have a presentation on Tuesday, and I’m going to be working over the weekend to get this fixed - so if anyone has any ideas on what’s going wrong here, I’d be massively thankful.


Hi Crow87,

If this is still occurring for you, please make a post on the answerhub in the Bug Reports section at http://answers.unrealengine.com so we can better assist you. With your report, please include your laptop dxdiag as well as reproduction steps so we can try to reproduce this on our end. Thank you!

I’ve seen posts on Oculus’ forums that indicate that laptops are not supported:

Actually, I should have updated this thread.

I’ve managed to get it working on all our machines now. There’s no Direct mode functionality with UE (but I think this is the case across the board), but the headset works fine on the laptop now.

Oddly, on the desktop machines, we have to set the Rift display options to *Portrait *- on the laptop it has to go in as Landscape (Flipped). So if anyone else is struggling to get their display to work properly, at least on Windows 8, give that a go!