Download

4.2 :: Admob, Achievements and leaderboards oh my!

I’ve been working from the 4.2 source for the past 2-3 weeks. And I love what I have been seeing with all the bug fixes and new features. My favorite of which is the name of the title!

In about 1-2 hours of playing around in blueprints (only) i was able to easily get google play services easily integrated into the game!
https://twitter.com/TheKRushin/status/470621449124720640.

I was curious and encourage other people to post screenshots!

Here is my progress, and curious what you guys have gotten to work!

Working
-Setup/Configured Admob (unit ID)
-Release Signed APK & Google Console SHA1 Access
-Play Store Developer App uploaded [alpha and beta tester groups of about 15 people :slight_smile: ]
-Play Game Services configured (1 Leader board, and 5 achievements)
-Configured UE4 with Leaderboard/Achievement ID’s? under Project Settings -> Android
-Authentication/Connecting with Play Game Services ( https://twitter.com/TheKRushin/status/470621449124720640 )
-Querying Play Games for achievements list http://i.imgur.com/WKJnlj4.png (No errors according to google)
-Displaying Ad Edit: 6/26 Works using latest 4.3 source].

-Game tested and runs on:
—Note 3 Good]
—Nexus 10 OK, DrawText doesnt work]
—Galaxy S1 It Runs! https://twitter.com/TheKRushin/status/471217732092846080]

Can’t get working (via BP, yet :wink: ) ?
-Display leaderboard
—Write to leaderboard (may need to be publish).
-Display achievements (“ready for testing”)
—Write to achievements

Anyways just seeing what you guys have tinkered with and got working.

Hey any updates on this at all? just curious becasue im at this stage now adding in ads and leader boards, did you get them to display correctly?

No I haven’t been able to with 4.2.1. I know some commits that fixed some things didn’t make it to 4.2 and i’m using it exactly like tappy chicken is.

I’ve been busy working on my thesis. So i haven’t had too much time to go back to my “fun” project. I’ll probably try it out using the latest source later tonight (where it should work).

Got a little bit of time and decided to run it using the latest 4.3 source (6/23-24) and we have admob working now http://i.imgur.com/8DtpyAP.png! All i had to do was run it using new source so it will work out of the box for 4.3 :slight_smile:

Can’t test achievements/leaderboards quite yet because packaging is broken and you must sign your app with shipping key for google play to connect properly (connecting wasn’t the issue) but if i had to guess it will work aswell!

Any updates? Like how can you test AdMob (test mode) as GooGle doesn’t allow live testing (false impressions) I was wondering if you were able to test the ads before publish?

Awesome, nice screenshot BTW. When publish please link us. Thanks

Yes and No.

You can run admob when its unsigned/using a debug key (atleast it fills the ad, probably not counting towards revenue). That is what the above picture shows using “Play on device”.

You are correct you can not test/connect to google play service (achievements/leaderboards) unless you signed the application with a release key Package Project -> Android with “Shipping” and “For Distribution” selected with proper Release Key setup]. I will try this out soon when i grab a source that it works on, which will be soon.

I’m stuck @ getting it on the play store / developers console -> I can not get the APK signed.

https://forums.unrealengine.com/attachment.php?attachmentid=6149&stc=1

I can’t find documentation or a tutorial on how to sign the APK? A tutorial or how to would be nice as I’m stuck now. I hope you can write a nice step by step on how to get the APK signed.

As for the debug key -> where and how can i find/set that with UE4.

Again thanks for taking the time to share some useful information and your progress.

Kind regards.

So I got it signed and uploaded to the Alpha stage. Yet the share link still doesn’t show anything after several hours. I’m planning a step by step as well but I don’t know if I did it right as it still doesn’t show @ the Google Play Store

Make sure you add yourself to tester list if you want to see it on the play store. Only people on that list will see it. See the second step of the group testing, can’t remember if you need this for individual testing (signing up to be a tester).

If you set up a group/community to test:

  1. Join Community/Group
  2. https://play.google.com/apps/testing/PROJECT NAME Ex: https://play.google.com/apps/testing/com.epicgames.UnrealBowling

I have it all working. You need to have a Google Community and anybody that is part of that community can opt-in for alpha and beta testing. I was confusing it with my Google pages. Still Game center and AdMob don’t seem to work with the 4.2.1 build (pretty strange as Tappy Chicken was released on the 4.2 base code)

It was released with 4.2 (+3 or 4) fixes that didnt make it to 4.2.

So how can I get it working at this moment? It’s important for the project that we can test it all before release :frowning:

Where can I find the 4.3 release you mention?

EDIT: well i downloaded the 4.3 source and I’m compiling it now. Will my 4.2.1 project work with the 4.3 source ?

  1. If you are using only Blueprints yes it should work fine (I’d recommend “open a copy” when it asks for you to convert project to be safe). If you are using code, it may need some fixing, we don’t have a comprehensive list of changes they made to the engine yet and will need a little tweaking.
  2. Just to be sure, incase you didn’t know (if you haven’t compiled from source before). After you compile the “development editor” for win64, if you want to package for android (build an apk to upload/distribute), you need to compile the android binaries. If your project is set to development Compile “Development” -> “Android” but if you are publishing it to play store and packing is set to Shipping then compile “Shipping” -> “Android”.

Hope this helps. Just be aware this is a preview for 4.3 so there are still some occasional bugs/crashes.

Thanks for this. Especially point 2 I didn’t know this at all. I’m now rebuilding the source with “Shipping” -> “Android” this way I can upload it with a signed APK, and still test it locally on my Galaxy Tab and Galaxy S3. Thanks a lot for the quick and explanatory answer.

Kind regards.

Seems with 4.3 my project doesn’t run at all anymore. Only a black screen and nothing. Guess Ill have to wait till epic starts focusing more on the mobile platforms (their #1 source of income) and actually get the gamecenter and AdMob support working. This is getting frustrating to be honest. Spending 3/4 months on a half broke engine. :frowning:

It can be frustrating till you learn how the engine is set-up, and the workflow. It was very frustrating for me a few weeks ago, but I seem to have gotten down Epic’s Project setup and workflow and it makes sense in hindsight.

I’d wait for 4.3, it will be featured test and working. Running from source is for the daring brave men :open_mouth:

  • All the default engine binaries for all platforms are compiled, and working
  • Its been feature tested by Epic’s Quality Assurance team. The check and run all the features, compile on all platforms, upgrade projects from previous versions.

Well I’m brave enough to try / go at it. Just seems strange my project doesn’t run at all anymore after the switch from 4.2.1 to 4.3… As well as building/rebuilding the source code for “separate” uses to say so. Isn’t there a way to compile the source for all platforms and packing selections?

Still can’t get my game/app to run on the latest 4.3 source (all commits from today including 09-07-2014)