4.18 HMD Left-Eye Flicker On Translucent Objects


I’m experiencing flickering at build stage in our HMD. The problem was isolated to the Left-Eye as seen here

Our teleport preview flickers in and out consistently with HMD movement, as well as a bush and background image we have, all with translucency in their materials.

I dont think it’s a DBuffer decal issue that was posted here earlier, I tried disabling that in the render settings as well as on individual materials. I also tried changing the Early Z-Pass in Render Settings from “Decide Automatically” to “Opaque and Masked” with no changes happening from that.

Originally, we were using forward rendering with MSAA. The supersampling was broken there, so we moved to Temporal AA with a custom supersampling that we enable on blueprint level. This could be the issue, as there are no flickering effects in editor or on screen. The issue only occurs in HMD on build packages, left-eye only.

Try disabling Occlusion Culling from Project Settings > Rendering > Culling with Instanced Stereo enabled.

I don’t understand why this solution works. Please someone explain

“Occlusion Culling is a feature that disables rendering of objects when they are not currently seen by the camera because they are obscured (occluded) by other objects.”

So the problem was the FOV of the HMD (VR Headset) was too big for the current Occlusion Culling Settings. So by disabling it, the problem goes away, but performance may take a little hit.