4.18.2 Daydream Google VR Laser Component for Google VR Motion Controller Not Working

I have not been able to get the laser and/or reticle to show up in any project (blank, third person, and documentation example project - all BP projects). I have been able to get all the buttons to the controller to work and the controller itself is visible with correct location and rotation. The Laser and reticle are just missing. Any thoughts or help would be appreciated.


Engine Version: 4.18.2;

Android Device: Pixel 2 XL running Android 8.1.0;

Headset:Daydream View 2017;

Target hardware: Mobile/Tablet, Scalable 3D or 2D;

Plugins: Google VR v 1.7(GVR NDK v1.80.0), Google VR Motion Controller v 1.7(GVR NDK v1.80.0);

SDK license accepted in APK Packaging;

Project configured for Android;

Configure GoogleVR to support… Tried all possible array combinations of Daydream 3.3 dof, 6.3 dof, and cardboard
Project configured for Goolge Play services;

Min and Target SDK versions both at:24;

Gradle enabled;

Support arm64 [aka arm64-v8a];

Support OpenGL ES2;

Moblie HDR disabled;

Android SDK see screen shot installed via codeworks:


I attempted to use the ‘Official Google Daydream Unreal’ link from Unreal’s documentation for addtional assistance (Quickstart for Google VR SDK for Unreal with Android  |  Google Developers), but I got this page cannot be found starting about 4 days ago. This link was working last week. The Unreal specific controller mapping page is also missing off of google’s site. Also missing - https://developers.google.com/vr/develop/unreal/daydream-in-unreal

From Unreal’s documentaion followed steps on Set Up Motion Controller for Google Daydream VR(including all prerequistes from Google VR Quick Start and Set Up Cameras for GoogleVR documentation):

Video on this page (seen here: GoogleVRMC - YouTube) shows a what appears to be the laser reticle moving in sync with the motion controller

I tried the example project from the link on this page (GoogleVR Motion Controller Example Project:
(https://epicgames.box.com/s/ya3fk0zs57ur49npm21ligcgxcve1g6j) loaded the project in 4.18 and deployed to my Pixel 2 XL and the laser component visable in the video was not there. I only get the controller itself just like in the blank and third person test projects I created. The pawn blueprint in the example project is set up exactly the way it is in my project.

From a bit of googlefu I found that I should be able to access the laser from the Google VR Motion Controller, but I can only find Get Laser Material, and Get/Set Laser Visual Component Tag.

I’ve also tried working with the Google VR Laser Visual Component directly in the pawn blueprint, but I could not get it to work or even attach to the motion controller when deployed.

Thank you!

It is not documented anywhere that I know of but the new google SDK in 4.18 does the ray differently.

You need to use the new “Google VRLaser Visual” component:


place a TAG on it. Then copy the TAG name into the motioncontroller component in this field “Laser Visual Component Tag”:


(even though the tooltip text says component name this must be the TAG :wink: ).

I played around with the Laser Visual Component Tag field before, but I put the GoogleVRLaserVisual Component name in instead. After reading this I went back and found the Component Tags array in the GoogleVRLaserVisual Component added a value and made that Laser Visual Component Tag in the motion controller match and it worked. Thank you!