Download

4.16.3 VR support is really bad

I have a very, very basic scene, with one cube, and a VR pawn consisting of a camera, a motion controller, and a sphere. There is some simple blueprinting involving overlaps and changing the color of the sphere when it overlaps the cube. This simple scene when played in the VR Preview is in constant reprojection on my gtx1070, and the editor crashes completely about 50% of the time when I exit it.

Anyone else having a similar, intolerably bad experience with 4.16.3?

I’m using a Vive, with the latest steam beta.

What were your results in earlier versions? And have you turned off SSR and SSAO?

Performance was hit and miss in earlier versions (with different projects), often reprojecting badly on simple scenes but sometimes being just fine, too. Also less crashes, but again, different projects.
I have not adjusted any rendering settings from the defaults, my scene has ~100 polygons.

Just as a test, I recreated a similar scene again, without my event handler, and that scene worked better but with occasional missed frames. What could I possibly have done that totally tanks performance and crashes the editor frequently? When it crashes, it says there’s no debug symbols so it can’t show a call stack. Can I change that, or get other crash information somewhere?

VR 4.16.3 performance

Hi,
Did you try the default VR project to have a point of comparaison ?
It will give you I think a good idea if it is coming from 4.16.3.

I mean, I just did this:

Start a new blank project, Desktop quality, no starter content.
Create a game mode, set the world to use my new game mode.
Create a pawn, set the default pawn in the game mode to my pawn.
Create a Camera in the pawn.
Select VR Preview.
Press ESC to exit preview
Editor crashed.

I opened the project again

Hit Play (VR preview). Worked. Hit ESC
Hit Play. Worked. Hit ESC.
Hit Play. Worked. Hit ESC
Hit Play. Worked. Hit Esc
Editor crashed.

Opened project again.

Hit Play. Worked. Hit ESC.
Editor crashed.

The same steps in 4.17.0 preview 3 show no crashes, but a lot of reprojection.

If I type “stat GPU”, the TOTAL statistic is averaging around 13.5ms with the max being 15ms. Is this normal, for an empty scene (with floor, skybox, and two sphere hands)?

If I start the default VR template, the total stat is 11ms and there’s little to no reprojection. No idea what the difference is, I guess some rendering quality or something, but to be honest I’ve had enough, and am installing Unity for a test.

I have a performance issues even in almost empty levels since 4.16.2 and crashes in 4.17.0.3. As far as i understand, this crashes in 4.17 a caused by changes in Motion Controller component. But the main project (with performance issues) wasn’t updated to 4.17 yet, so i can’t say about performance.

I wondered about the motion controllers too. Sometimes they were not spawning correctly. But in the end it didn’t seem to matter whether they were turned on before running the preview, or if they automatically turned off during the preview. There were performance issues and crashes in all cases. I created the simple scene in 4.15 too and it also had performance issues (didnt see the crashes). I don’t remember it being as bad as that when I was working on older projects in 4.14 and 4.15 though, and think something has seriously regressed. I heard something about the latest steamVR change causing a 15% performance hit due to some change in CRC (I think I saw that on the Vive reddit), maybe that’s all it is. Either way I’ve had enough of frustration with UE4 for a while so I’ll try the same things in Unity and report back. If anyone has any Unity experience and can make a comparison of the VR experience in it compared to UE4 then that’d be very interesting.

I have a rift and gtx 1080 ti -performance seems consistently good for me in 4.16.3.

When I play in preview though, the controllers do not seem to spawn correctly (I see them but they dont receive events.)
If I launch play while editing in VR though, it works every time.

I’m having exactly the same problem. The VR preview mode keeps crashing Unreal when using the ESC key, its not every time but every third or fourth time, this is a serious issue, is there a work round or fix possible? I’m using the VR template with the Vive.

Can you look into your saved folder for the crash logs and post them so we can see what might be causing the crash.