[4.14] Strange pawn camera behaviour after using foliage editor

In a couple of my 4.14 projects I find that the camera rotation on my pawn in the game becomes wildly incorrect, eg pitch input creates roll, yaw input creates pitching etc. The starting position and spring arm behaviour of the camera is also incorrect. On opening those projects the camera functions normally until I enter the shift + 4 foliage tab, then the camera bug occurs. Problem is corrected and not present after restarting the editor and reoccurs consistently after selecting the foliage tab.

Hi ag858,

I was unable to reproduce your issue, these are the steps I took:

  • Create a new third person template Blueprint project for desktop
  • Play in the default map to confirm normal behavior
  • Exit play and press shift+4 to enter foliage editing mode
  • Play in editor while in this mode
  • Move around and confirm camera still behaves as expected

Could you test in a template project as well? Also, let me know if my test didn’t properly address the issue.



I’ve uploaded a video of the bug here.
I just did the same steps above to reproduce the bug at my end, but I clicked on the foliage tab instead of using the keyboard shortcut. Yes, I can reproduce the bug in all of the starter templates I’ve tried, if I understand you correctly. Interestingly standalone mode is not affected by this bug. And after using the VR preview and going back to PIE, the camera gets locked to yaw rotation only but still with incorrect behaviour.

I wasn’t able to reproduce this issue using the same steps. This may be related to the editor preferences, try resetting your preferences to default.

Another thing that stood out was that you got an error message requesting a disk be inserted to run ue4editor.exe. That is pretty unusual and it makes me wonder if your engine was installed properly although, that shouldn’t be the cause of the issue you showed.

If you reset the preferences and this bug still occurs in blank projects please provide your dxdiag and I can go on from there.

To do this type dxdiag in your command prompt and when the window appears save all information and post the text file here in a comment.


dxdiag file

Yes, the problem persists after resetting editor preferences. DxDiag posted above.

About the error message requesting that a disk be inserted, I started getting that after I installed a new system drive and reinstalled UE4. I remember uninstalling and reinstalling the engine in an effort to fix it but I kept getting that error message.

That is very strange, I don’t see anything that sticks out about your hardware. You’ve also claimed this reproduces in a blank project. Just a few more questions before I log a report for this.

  1. Could you provide a bugged project (the third person template will do just fine.)
  2. Could you also provide your full log after you broke the camera. To get this go to your project directory >Saved>Logs>YourProjectName.txt
  3. Does this occur with other engine versions?
  4. Is there any way for you to correct the issue or does it stay permanently broken?



Sorry for the delay getting back to you.

  1. bugged project download link

  2. log download link

  1. No, I’ve tried to replicate with 4.13 and 4.12 but it only happens in 4.14.

  2. The issue can be corrected by simply closing and restarting the editor.

Also, I’ve noticed that the camera bug can be triggered by going to the Paint tab and Landscape tab as well as the Foliage tab. The Geometry tab does not seem to trigger the bug.

Thank you for all the information, I still was unable to reproduce the issue with your project and following the same steps in the video. Just to rule out this as a unique issue with your system, could you ask a friend to this on their machine to see if the camera orientation breaks?

If this is only happening for you I would recommend either reinstalling the engine Or waiting for our hot fix to come out (it will be very soon) and test again to see if the bug still occurs.

I’m a little hesitant to write a JIRA for this since I can’t repro the issue and you are claiming a regression (bug doesn’t occur in previous versions). We take regression issues pretty seriously so I need to make sure this is a legitimate issue first.

Also, you can just leave a comment here and it will put this issue back in my list of issues that needs attention.


I’ve deleted all engine versions from the launcher, uninstalled the launcher, then manually deleted all traces of the software that I could find from my system (in the hidden APPDATA folder) before doing a reinstall. But the bug in 4.14 is still there as before. Interestingly, the error message where I’m asked to insert a disk is also there as before.
Is there a more thorough way to uninstall that I’ve missed maybe?

I’m sure this is a unique issue with my system, though I don’t have any other computers/friend’s computers I can test this out on.

I am getting the same behavior on my machine with 4.14.3 and I am pretty sure that it is (at least in my case) related to a connected VR (Oculus) headset.

After visiting foliage or landscape mode the next “Play” in regular mode ties the view to the position of my rift lying next to me on the desk. Depending on how its position, I see the same movements as in the video. I can restore normal behavior by reloading the project, or by killing the oculus services with the task manager.

This happens independent of the VR mode being used or the experimental VR editor being activated before. I hope that helps to track the issue down.

Thank you for bringing that up. Your case may be a little different from OP. Would you mind checking your editor preferences. There is a setting under the Play section that says “Viewport Gets HMDControl” if that is checked that may be causing the behavior you see. If that is not checked then this is probably a bug.

Sure. I checked the editor settings and the option is disabled, so looks like a bug. Also enabling, playing, disabling, playing does not restore the original behavior.

I did a bit more testing. After a restart I enabled the setting. It works as intended: Viewport is bound to Oculus. Disabling it reverts back to normal. However after once clicking “landscape” or “foliage” I get the issue again - independent of the setting. Interestingly the view that I get in the error case differs from the intended setting. While the “Viewport Gets HMDControl” has a normal camera position, the error case has a camera on about ground level.

Hi all,

to dirkr for providing additional information we were able to link this post to this issue: Unreal Engine Issues and Bug Tracker (UE-39587)

You make track the issue as it is reviewed by our staff. Keep in mind this may not be prioritized or fixed soon.



I had exactly the same problem few minutes (Using 4.15).
I fixed it removing the oculus device.
So it is obviously a bug related to a VR device.