4.13 VR template - teleporting through the roof

I have a 3 story building, I have some stairs that go up and then the next stairs are right next to them up to the third level.

How do I stop the ability to be able to teleport through to the top level from the bottom level, I have tried using multiple nav mesh boundaries for each level but it still allows me to teleport?



try to look an navmesh tutorial through youtube.

Looks like your Navmesh it’s not working properly.

I have tried multiple ways of doing the navmesh, I’ve had one just for the bottom floor only and one for the top floor, and one that just covers all of them. If anyone knows how I can solve this it would be much appreciated.

I’m having exactly same issue. This happens on BP motion controller map too. If you add second floor (or roof) with static mesh to that map and add nav mesh bounds volulme, and point the teleporter to one of the static mesh boxes, it teleports you up to second floor. But it doesn’t do that with the brush boxes. I need a way to stop this. You can also point at the ceiling from first floor and it teleports you to second floor.

I can confirm the same thing happens here.

I can confirm that this happens to me too. A solution for this could be to get the z value of motion controller and block the teleporter to teleport anything outside of certain values. Like -+50 cm. But I didnt had the time to look into it.

or just lower the “Project Nav Extends” in the “trace teleport destination” fonction in the BP_MotionController blueprint (a value of 100 will probably solve the issue :wink: )

I’m having the same problem but not on my floors, they are wide open, no narrow hallways. I have the problem on my stairs, can only teleport to the first step. I wonder if this has something to do with the width of the RoomScaleMesh component not fitting in your hallway so it jumps up to the second floor? Please let me know if someone figures this out.

Can you post a picture of what your Nav Mesh looks like? I had a similar issue and to fix it I had to adjust the agent radius property in the Navmesh settings to get it to generate wider paths. Here is a link to an answer hub post that talks more about it.

I’m having the same problem. Have you found a solution?

Has anyone found a solution to this? I’m having the same issue of going through floors if I don’t aim the motion controllers just right.

Migrated from Epic’s VR template to mitch’s much more complete VR Content Examples implementation (similar to the teleportation in “The Lab”). Works very well with simple and complex mesh colliders too, and you can quickly and precisely define your TP zones.

This is exactly how I got around it also. It’s a bit more work to define where you can teleport to. But it works as intended

Hi everyone,

I have the same issue. In my house project.
Impossible to add the second floor without teleport on it when my trace colide with an object.
Do you find something ?

Best regards.


Here is the solution: go into the function called Trace teleport destination (1st image), in the Break hit result find the Normal, break it into floats and check for the Z to be positive. If it’s negative it points downwards so make the IsCeiling boolean true (of course create the boolean first). Also as Jamis mentioned lower the Project Nav Extends variable (100 worked for me). This will avoid accidental picking the next floor. Now go to the MotionControllerPawn (2nd image), check if the IsCeiling variable is true, if yes, set IsTeleporting false and disable the teleporter.

Screenshot 2017-07-08 00.55.47.jpg
Screenshot 2017-07-08 00.56.55.jpg


Thank you so much Fisher! This helped me fix a lot of teleport issues in my project! I built a 25000+ sq ft house for VR and was having major teleport issues from floor to floor. Your walkthrough helped big time! Thanks again!

Hope someone can help me. I’m having the same problem, but I’m using an Oculus Rift.