Download

4.13 VR Template - Teleport rotation

If I rotate myself 180 degrees in real life, teleport moves me facing away from the direction I was aiming. So it’s rotating the area I’m in to point at the aim direction, based on the play space rotation and not my camera direction. Is this only for me, or how people like it or what?

Yeah I noticed this as well, I created a bug report on answer Hub
https://answers.unrealengine.com/questions/465461/413-vr-template-teleport-preview-bug.html
so hopefully it gets addressed

I disabled teleport rotation and found things to be much better. I’ve played quite a few Vive games and demos so far, and not one of them have any sort of rotation mechanic. It’s just confusing, and probably shouldn’t be turned on by default.

Thanks, I assume they’ll sort it out.

This is already a known issue, although its slightly different there are very similar. UE-33962 Unreal Engine Issues and Bug Tracker (UE-33962)

How do you disable the teleport rotation? Also, is there way to hide the room scale boundary as well?

Edit: Nevermind, found the answer to both questions. MotionControllerPawn, disconnect TeleportRotation. And set hidden in game or delete RoomScaleMesh component in BP_Motioncontroller.