Download

4.13 VR Template Base Eye Height issue

Hi there,

please help me figure this out:

When I open the new 4.13 VR template with motion controllers and start a VR preview (HTC VIVE), my player camera is offset.
To be precise: If I lay the HMD flat on the (real) floor, it is BELOW the floor in VR.

After moving the floor BSP object I found out that the offset is exactly 64, which corresponds to the default Base Eye Height setting.
Unfortunately, changing this value has no effect.

I COULD move all objects down 64 units, but that clearly is not the right way to do it.

Any idea? Thanks!

-Robert

I am not seeing this, what is the Z location of your floor and VR Pawn?

All is default:

The VRPawn is at Z = 200 and the floor BSP has its top-facing polygon at Z = 200 as well.

Okay, nevermind… after I completely uninstalled the VIVE software and set up everything from scratch it now works. I have no idea, what had happened there. Now it works.

I find I have to run the Vive room setup every now and then if I have issues like this. And there is sometimes an inconsistency with the VR headset sitting on the floor or not between different games/demos.

I need to do the quick-room calibration constantly on my Vive as it gets offset fairly often.

Also, while we’re on the topic - is there a consensus as to how to have a Vive and Rift supporting project ? Am I right in thinking the Vive needs the pawn at ground level (then Vive offsets from there) whereas the Rift is some half-height setting ?