4.13 planar reflection BUG on metal/es3.1

1.Here are two screenshots to show what I mean,the first one is in SM5,and the second on is in es3.1,you can clearly see that everything reflects fine in SM5,however,in es3.1(mobile),the bridge which below the clipplane has been rendered as if above the water.And I have tested this on metal enabled iphone6 and iphone6s,both have this issue.

2.Also,I find there’s a bit different between rendering in SM5 and in es3.1,please look at the trees which being reflected in water.In SM5(screenshot above),the edge of the trees look more clean,while in es3.1 not.How can I optimize for es3.1?

3.By the way,is there a way to specify which device to use/enable planar reflection?Such as I want iphone6s or above to use planar reflection,but iphone6 or below to disable this.



I have found two similar issues posted with 4.12:

Yes this is the exact same issue that I posted. Clipping Plane simply is not yet implemented in OpenGL but it is tracked here: Unreal Engine Issues and Bug Tracker (UE-34762) so make sure to upvote it!

Although the issue is the same, the implementation will be separate for mobile vs Linux OpenGL. We have a separate ticket (UE-32449) tracking adding support for a planar reflection clip plane to the mobile renderer.

We did some work on this a week or two ago and at the moment it’s scheduled to be done in time for 4.14.

  • Jack

Thanks! What about the last 2 questions?